Hi, while playing around in CS4 and coding with as3, on some custom made class I came across a pro... an annoyance.

First is the reserved keywords, which, if you want to follow some good coding guidelines, you will not use the such as "height" "width" "size" as a property name.

Second, if a parameter variable holds the same name as a class property (which occurred as I wanted to keep variable names simple and self-descriptive).

So to distinct the 2 variable names above, the use of "this" or altering the name of the property by adding an underscore "_" is required.

So it got me wondered if I should just keep my property names as I see fit, simple and relevant, and force myself to make the use of "this" all the time as a coding practice, or, not bother with using "this" but bother with always using the "_" instead.

I'd like to hear the point of view that you veterans have here.