dcsimg
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: flash not working with IE

  1. #1
    Junior Member
    Join Date
    Mar 2010
    Posts
    8

    Question flash not working with IE

    Hi guys, first post in the forum.
    I designed a landingpage with a preloader. I inserted the .swf into an html document and then uploaded the file.
    I tested it on Firefox, works fine. On IE, it loads one time, plays the movie but when you refresh, the page freezes on the preloader.

    Here is the link of the page:
    http://imajinn.pcriot.com/test/edel-landingpage.html

    Would someone know the reason why IE doesn't reload the page properly?


    Thanks for the help

  2. #2
    Senior Member
    Join Date
    May 2008
    Posts
    332
    Are you by any chance using a conditional statement for IE in your preloader? There was a similar situation posted recently here:
    http://board.flashkit.com/board/showthread.php?t=810720
    Take a look and see if any of that applies.
    Best wishes,
    Eye for Video
    www.cidigitalmedia.com

  3. #3
    Junior Member
    Join Date
    Mar 2010
    Posts
    8

    Internet explorer and Flash!!

    I read the thread you sent me to but played with the Divs but didnt fix the problem.
    Here is the script I used:

    stop();
    this.loaderInfo.addEventListener(ProgressEvent.PRO GRESS,
    checkingProgress);
    function checkingProgress(event:ProgressEvent):void{
    var procentLoaded:Number = event.bytesLoaded/event.bytesTotal*100;
    bar.scaleX = procentLoaded/100;
    if(procentLoaded == 100){
    this.gotoAndPlay(2);
    }
    }
    So I deleted the preloader from the movie and tested it on IE. Loads fine but when I refresh, the page loads with the preloader!!!
    http://imajinn.pcriot.com/test/edel.html

    Thanks for the help Eye for video

  4. #4
    Senior Member
    Join Date
    May 2008
    Posts
    332
    If you deleted the preloader from the movie then I'm still accessing the old version because I'm still seeing the proloader. I'm deleting the cache every time so I know I'm getting the most current version.
    Doing a direct download here:
    http://imajinn.pcriot.com/test/landingpage.swf
    the problem still persists in IE so it's not the html/javascript that's the problem its the Flash itself.
    Is the space in PRO GRESS just a typo or is it in the code that way?
    Code:
    this.loaderInfo.addEventListener(ProgressEvent.PRO GRESS,
    Of course it should all be one word.... but I don't know if that's what's causing the problem.
    Did you also try the preloader code from that link? minus the IE conditional and edited to get you to frame 2 of course. Might be worth testing.
    Best wishes,
    Eye for Video
    www.cidigitalmedia.com

  5. #5
    Junior Member
    Join Date
    Mar 2010
    Posts
    8

    Flash and IE

    I checked the code, the PROGRESS is in 1 word
    After deleting the preloader and adjusting the .fla, it does work and reloads each time.
    Just dont understand why this preloader I have previously used doesn't work for this file!!!!

    http://imajinn.pcriot.com/test/edel.html

    Thx for your time and help Eye for video

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center