PHP User Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: bbcode_highlight in ..../includes/functions.php on line 4197
Flash CS5 giving me headaches No Bold style for Arial Unicode MS
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: Flash CS5 giving me headaches No Bold style for Arial Unicode MS

  1. #1
    Junior Member
    Join Date
    Aug 2008
    Posts
    27

    Flash CS5 giving me headaches No Bold style for Arial Unicode MS

    Hi,

    We recently upgraded to Flash CS5 and now are facing a lot of problems.

    I created a static textfield on Stage with publish settings Flash player6 As1.0

    I selected the settings as shown in attached screenshot.

    The problem is I can't select Bold from styles as it is greyed out. However this work fine in Adobe Flash CS3.

    Anyone knows what I may be doing wrong
    Attached Images Attached Images

  2. #2
    Member
    Join Date
    Aug 2010
    Posts
    65
    i think you need to embed the font to your library first. And please post to flash general help, this is not related to as3

  3. #3
    Senior Member
    Join Date
    Apr 2002
    Posts
    2,849
    I ran into this the other day too. Here's my guess: Fonts have different character sets for italic and bold (in some cases they're completely different font files). In previous versions of Flash it created fake bold and italic characters, simply taking your font and making the letter thicker, or skewing it. In CS5 they decided to stop doing that, and instead use the "real" fonts. Problem is if you don't have the "real" bold font installed, you have no option to use it.

  4. #4
    Junior Member
    Join Date
    Aug 2008
    Posts
    27
    Thanks rdoyle720 for your explanation.
    Why is it that if I set the text dynamically then I am able to make it bold?

    e.g.
    Actionscript Code:
    _root._txt = "<b>Help</b>"

  5. #5
    Senior Member
    Join Date
    Apr 2002
    Posts
    2,849
    You'd have to ask Adobe why that is.

    I just found the old "faux bold" setting, it's now buried in a menu. Go to Text>Style>Faux Bold.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center