dcsimg
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: Font embedding settings wont stay selected

  1. #1
    Junior Member
    Join Date
    Apr 2011
    Posts
    25

    Font embedding settings wont stay selected

    Under what circumstances might the embedded font selections not stay selected? I have a group of dynamic text boxes embedded in a movie clip, programmed to run as a timer. The timer dosn't display the numbers and I get a message on the output box noting that "Fonts should be embedded...etc" I had the same trouble with the score, but when I set the embedded fonts, it works now and those settings keep. They will not stay selected for the text boxes inside the timer movie clip. I can go into font embedding, select any of them, hit okay, go back in and they'll all be unselected.
    Why is it doing this? I have to assume, this must be the reason the timer isn't showing the numbers, especially now that the score display works after setting it for that.

  2. #2
    Flash Genie letschillout's Avatar
    Join Date
    Feb 2007
    Location
    31.52949, 74.347272
    Posts
    146
    Hi,

    the dynamic and all other text input should have font embed
    when u embed font embed numbers also to display in dynamic text
    in font properties u can set unselected text by setting Ab.

    time will display when u embed numbers and punctuation in it.
    Charag - 3D, Flash Games, Animations,
    Website Development & More...


  3. #3
    Junior Member
    Join Date
    Apr 2011
    Posts
    25
    Right, I know those options have to be set for the characters to appear; the problem is, these three specific text boxes inside the timer movie clip, will not keep those options under font embedding selected. If I go into embedding, and select numbers and punctuation - or any option there - and click okay and go back into the embedding option, everything is unselected. On the left side of the font embedding panel, it lists the font that reads something like:
    \/Arial:
    Black (Font 1)

    Selecting any of these will show what options were selected under them previously. Any other text box in the program will stay on the selected, embedding enabled font that was chosen when it was set - except the three inside the timer movie clip. If you set the embedding properties and go back in, it shows a new font with no options selected. Say you first go in and select options while under the font Arial>Black (Font 1), click okay and go back into font embedding - any other text box will show Arial>Black (Font 1) as still selected, with all the embedding option you previous choose still checked. These problem text boxes, instead, will show the font now being Arial>Black (Font 2) and all of the embedding options are unchecked. It will keep doing this every time you select options and click okay and go back in, the Font # advancing by 1 every time. You can select one of the previous fonts on the left, and it will show the embedding options selected, still saved to that font - but it wont stay selected for those text boxes.

    I tried creating new text boxes inside the box, copied working text boxes from elsewhere in the program - same thing. I even went into a blank project, to see if I could build the movie clip from scratch and simply call everything by the same variables and what not, then paste that into the program and replace the faulty clip - yet for some reason the problem persisted in the blank project. I had to close Flash entirely and reopen it, before the blank project would hold the embedding options. It was getting late at that point, so I haven't tried doing the rebuild in a blank project yet. I would like to understand why it's doing this in the first place, because I have a feeling that, even if I can get it to work and put the movie clip together properly in a blank project, when I move it into the the full program, I wont be surprised if the problem manages to occur in the new clip. I have a similar problem with a separate text box in this program, that is giving me another problems; it'll work fine in a blank project, but is stricken with the same problem as the one I'm trying to fix when it's moved into the program...

  4. #4
    Junior Member
    Join Date
    Apr 2011
    Posts
    25
    Whatever was causing this problem, it's no longer a problem. I created text boxes that were appropriately set in a blank project, moved them into the full program, gave them the proper variables; made sure the embedding options were set and stayed set - which they did - and the timer works!
    Consider this thread closed, problem solved!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center