A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: MovieClips and backbuffer help in Flash Builder

  1. #1
    Member
    Join Date
    May 2010
    Posts
    32

    MovieClips and backbuffer help in Flash Builder

    So here's the thing, I've been trying to switch from coding in frames to class-based. I've looked at some examples online and they mostly use embedded images like jpg, gif and so on. I'm used to movieclips because of the vector graphics and frame labelling for easy animation control (gotoAndStop).

    Does anyone here have or know of an example that uses movieclips because right now I'm clueless on how to add them to stage. It doesn't have to be complex, I just need to know if it still uses the backbuffer or something else?

    I'm going to guess that the jist of what I want will be in the GameObjectManager, GameObject and GraphicsManager class?

    Thanks in advance! I really need your help!

  2. #2
    Mod cancerinform's Avatar
    Join Date
    Mar 2002
    Location
    press the picture...
    Posts
    13,448
    If you have Flash CS5 you prepare MovieClips with animations there and export them as Flex components. You can then control them in Flash builder with AS. Was that your question? Otherwise you just prepare a Flex component in Flash builder.
    - The right of the People to create Flash movies shall not be infringed. -
    | www.Flashscript.biz | Flashscript Biz Classes/Components |

  3. #3
    Member
    Join Date
    May 2010
    Posts
    32
    Yes it did. Based on that I did some research and appears I don't need to use flex the way I code, I can just stick to actionscript projects. I still have one problem though. I tried adding a movieclip I exported to SWC (I did check the "export for actionscript" box) using flash CS5 and imported it into my project.

    Tried adding it to stage and nothing shows. Is this because I created a class definition for the item I'm trying to add? Or is the problem the fact that it has several parts that haven't been exported for actionscript?

    I added text fields to the stage successfully so don't think that's where the problem lies.

  4. #4
    Member
    Join Date
    May 2010
    Posts
    32
    Ah, yes it WAS because I created a class definition for the movieclip, so there must have been an overwrite. Thanks for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center