H.264 video stuttering until loaded?
A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: H.264 video stuttering until loaded?

  1. #1
    Senior Member
    Join Date
    Apr 2002
    Posts
    2,849

    H.264 video stuttering until loaded?

    Months ago I created a video player for my company. It uses a Video object, and typically plays back H.264 videos. All has been fine and dandy until we started producing larger, longer videos. When playing back a longer, larger video the playback will stutter until the video has completely loaded (even if it has already downloaded the portion of the movie it's currently playing).

    I assumed there was a bug in my player, but after optimizing, tweaking and even removing everything except the code that loads the video it still stutters until it's completely loaded. I even tried re-encoding the video -- no luck.

    As I said these are long, large videos so waiting until they are completely loaded isn't a good option.

    Given that it doesn't seem to be my player, I'm wondering if this is a known issue with H.264 videos in the player? I'm running version 10.3 in Internet Explorer 8. The video in question is 640x360, 24fps.

  2. #2
    Senior Member
    Join Date
    Sep 2010
    Posts
    324
    What is the video bitrate?
    VM

  3. #3
    Junior Member
    Join Date
    Sep 2011
    Posts
    25
    It sounds like you may have encoded the video in question with set key frames ticked. If this is the case, untick it and re-encode the video, otherwise goodluck =]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width


HTML5 Development Center

Poll by Flashkit.com