PHP User Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: bbcode_highlight in ..../includes/functions.php on line 4197

PHP User Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: bbcode_highlight in ..../includes/functions.php on line 4197
play next video or play first video
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: play next video or play first video

  1. #1
    Member
    Join Date
    Sep 2009
    Posts
    57

    Exclamation play next video or play first video

    I would like to refine my code to play the first video when it is on the last item of the xml. So far, the code

    Actionscript Code:
    setupvideo(_global.file[i + 1],i + 1);
                            _root.iinfo.tag.tagTxt.htmlText = _global.info[i + 1];
                            _root.iname.tag.tagTxt.htmlText = _global.tag[i + 1];
                            _root.iname.update();
                            _root.iinfo.update();
                            tags();

    works great. Except when it gets to the last item on the xml. Then it loops on a single random video. Please help!

    I have even tried this code,

    Actionscript Code:
    if(_global.file == 0)
                        {
                            setupvideo(_global.file[0],0);
                            _root.iinfo.tag.tagTxt.htmlText = _global.info[0];
                            _root.iname.tag.tagTxt.htmlText = _global.tag[0];
                            _root.iname.update();
                            _root.iinfo.update();
                            tags();
                        }
                        else
                        {
                            setupvideo(_global.file[i + 1],i + 1);
                            _root.iinfo.tag.tagTxt.htmlText = _global.info[i + 1];
                            _root.iname.tag.tagTxt.htmlText = _global.tag[i + 1];
                            _root.iname.update();
                            _root.iinfo.update();
                            tags();
                        }

    but it still does not work.

  2. #2
    Prid - Outing Nig 13's Avatar
    Join Date
    Jul 2006
    Location
    Norway
    Posts
    1,864
    please provide FLA file
    I am back, guys ... and finally 18 :P

    BRING BACK THE OLD DESIGN!! OR AT LEAST FIX THE AS TAGS

  3. #3
    Member
    Join Date
    Sep 2009
    Posts
    57
    Im sorry, but I no longer provide fla files. I have posted several fla files over the past months and all that has happened that my work was stolen from me. Sorry. What do you need from the fla in specific, the xml setup?

  4. #4
    Prid - Outing Nig 13's Avatar
    Join Date
    Jul 2006
    Location
    Norway
    Posts
    1,864
    Oh, sorry to hear that, but I'll need to see how everything is set up in your FLA in order to understand that code. PM me the FLA file if you want - you can trust me
    I am back, guys ... and finally 18 :P

    BRING BACK THE OLD DESIGN!! OR AT LEAST FIX THE AS TAGS

  5. #5
    Member
    Join Date
    Sep 2009
    Posts
    57
    Well I already found a workaround to the problem, but if you still wish to help me i can send you the fla in a pm so that the problem can be resolved rather than having a workaround.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center