Slideshow does not stop looping
A Flash Developer Resource Site

Results 1 to 13 of 13

Thread: Slideshow does not stop looping

  1. #1
    Junior Member
    Join Date
    Dec 2011
    Posts
    6

    Slideshow does not stop looping

    Could you please tell me how to make it stop looping over and over again?
    Everything works fine in 3dfa, but after exporting it into the browser the slideshow is going through all the frames, I've made prev n next buttons for it, it works without a problem while played inside of 3dfa but it just doesn't seem to work in the browser:/ It's acting like there were no rules about it I want it to stop and wait for click...
    Thanks

  2. #2
    Senior Member zoranvedek's Avatar
    Join Date
    Aug 2001
    Location
    Wagoner OK
    Posts
    892
    ...how do you have it set up?

  3. #3
    Junior Member
    Join Date
    Dec 2011
    Posts
    6
    Well...
    There is a slideshow element with 5 slides, each of them contain graphics. There are 2 buttons prev and next. Both have properties and the action is assigned to the buttondown only, and it's assigned to slideshow1 to the "previous" or "next" action (not a particular slide nr). There is also showslideshow event as I want it to slide in into the scene, but the slides just go crazy repeating them selves over and over as the slideshow appear in the scene.
    Thing is that it works fine but when I export it and click play in browser the animation acts like described, same on IE and FF... don't know what to do

  4. #4
    Senior Member zoranvedek's Avatar
    Join Date
    Aug 2001
    Location
    Wagoner OK
    Posts
    892
    ...try setting your show slideshow action to 'parent elements' only, and make sure "looping" is turned off. If that doesn't help I can look at it for you, but you'll need to zip it up and upload it.

    -J

  5. #5
    Junior Member
    Join Date
    Dec 2011
    Posts
    6
    putting show slideshow into parent elements does not change a thing...
    here is how it behaves as the exported and standalone animation: www.survi.*********.pl/page/thegame.html
    and here is the file containing the whole project... don't ask me why I do this, just halp me if you can
    http://hotfile.com/dl/137526457/a8b81e5/page.rar.html
    I think that there is something wrong with my 3dfa, on the beggining there were some 5sec time to export the movie, now it takes arond a minute to write it into the disk... don't know why... anyway take a look and tell me wtf

    ps. by looping you mean the whole movie? well it doesn't make a difference what I set to it, the movie ALWAYS repeats itself unless I put the "Delay" event that lasts xxxxxxxx seconds
    ps2 some f*** antispam filter is blocking me from posting links geeeeeeeeeeezz come on!!!!!!!!!!! i will send u a pm with the link:/
    Last edited by kanything; 12-14-2011 at 06:53 PM. Reason: btw

  6. #6
    Senior Member zoranvedek's Avatar
    Join Date
    Aug 2001
    Location
    Wagoner OK
    Posts
    892
    I'm using an older version of 3DFA currently, but I removed the extra 'show slide' from your buttons(you have 4 on each, you only need one) and it worked correctly. I'm downloading the most recent version now and will check it in that as well, but I am assuming that was your problem. It took a loooooong time to export for me as well. I haven't looked into why, but I bet it has to do with embedded objects.

  7. #7
    Senior Member zoranvedek's Avatar
    Join Date
    Aug 2001
    Location
    Wagoner OK
    Posts
    892
    ...works in version 4.9.8.7 as long as I export to Flash 8. Just remove the extra show slides from your buttons. I also changed your delay to 1 second as opposed to 36000 seconds, and that sped up the rendering time considerably.
    Attached Files Attached Files

  8. #8
    Junior Member
    Join Date
    Dec 2011
    Posts
    6
    cannot open that file you posted, 3dfa crashes, no error report....

    ok I removed the extra show slide from both buttons, again it works fine played inside of 3dfa, firefox and IE are freakin with the slideshow:/
    which delay you mean? at the end of the movie? I think it should not affect the rendering which is dramatic on this project....
    Last edited by kanything; 12-15-2011 at 06:24 AM.

  9. #9
    Senior Member zoranvedek's Avatar
    Join Date
    Aug 2001
    Location
    Wagoner OK
    Posts
    892
    you're rendering 36,000 blank frames. That translates to 2 and a half hours of delay . Trust me, it affects your rendering time. Make sure you rendering in Flash(not Gif) and that you're using Flash 8 as your setting.

    You will have to use Winzip or a similiar program to uncompress what I uploaded previously. It works fine on my end in 2 different releases of 3DFA and in all browsers: 4.9.8.4 and 4.9.8.7-Firefox, IE, Chrome, and Safari...
    -J

  10. #10
    Junior Member
    Join Date
    Dec 2011
    Posts
    6
    come on man, WinRar is one of the basic programs running on my system, which is win xp pro sp3, with photoshop 7, dreamwaever and 3d studio max 9 on the stage
    don't know what's wrong with my installation of 3dfa, but really - it crashes when I load the file FROM the zip u uploaded....
    anyway I thought that Flash is a format smart enough that it will not render xxxxx frames for nothing, just stop at the last frame and count seconds..... is this really so ridiculous?!
    and what about the vid I send u in the PM?
    Like I said - doing changes as u said makes no difference....
    wish I knew dreamweaver good enough to create whole site with it.... but having so many interests just mixes my mind

  11. #11
    Senior Member zoranvedek's Avatar
    Join Date
    Aug 2001
    Location
    Wagoner OK
    Posts
    892
    ...I don't know what to tell you, try re-installing 3DFA. I'm getting no crashes on my end. Windows traditionaly uses Zip files, so you should be able to extract it to a new folder and open it with no problems. I suspect that your problem is somewhere other than your movie file.

    What version of 3DFA are you using?

  12. #12
    Junior Member
    Join Date
    Dec 2011
    Posts
    6
    3dfa4r5

  13. #13
    Senior Member zoranvedek's Avatar
    Join Date
    Aug 2001
    Location
    Wagoner OK
    Posts
    892
    Try the newest one 4.9.8.7.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center

Poll by Flashkit.com