A Flash Developer Resource Site

Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Apr 2012

    transparent problem

    I have three buttons that are fine, and three that are transparent.
    I can't figure out why.
    I believe I created all six the same way.
    I have checked all of the button's properties and all of the Alpha settings are at 100%

    If I simply draw a rectangle over my bg image, it is transparent, and it's alpha is 100%.

    I don't want these to be transparent.
    Any ideas?

  2. #2
    Join Date
    Feb 2012
    Cairns - Great Barrier Reef - Australia
    Dude its not really enough detail to help?... Is the bg image and buttons on separate layers?... or have you made them all on 1 layer?...

    On the fly all Ive got is.. Select the bg image (as it may be covering buttons?)... once selected "right click"...choose "arrange" and this will give you the option to move it to the back?....

    Defy the boundaries!.. NEVER surrender to the code!!!.....

  3. #3
    Junior Member
    Join Date
    Apr 2012
    The BG image is on a separate layer, and it does have an alpha of 50%.

    The buttons are all on separate layers each.
    All of the buttons are placed over the background image.

    Three of the buttons appear fine, but three are transparent.
    I've checked the buttons over and over, and can not see anything different in any settings, and they all have alphas set to 100%.

    I'm not sure what else I can tell you about the problem.

    If I try to draw a new rectangle over the background image on the stage, the rectangle comes out transparent too, yet it's alpha is set to 100%.

    I've also sent the BG image to the back, and all of the buttons to the front.
    Last edited by xTiltx; 04-10-2012 at 12:10 PM. Reason: more info

  4. #4
    Senior Member
    Join Date
    Sep 2010
    Are you sure you haven't changed the color selection? perhaps the fill color is the same as the background... making it appear as though it's transparent.... or the "fill" color is turned off, and the stroke is the same color as the background.
    Play around with the color selections, and make sure the fill is turned on.
    Best of luck,
    Video Man

  5. #5
    Junior Member
    Join Date
    Apr 2012
    Thank you guys, but I figured it out!

    It was the order that my layers were in:


    This put the background under the last three buttons, but on top of the first three.

    I moved my Background layer to the bottom of the list and walah!

    I never realized the order of layers had such an effect.

  6. #6
    Junior Member
    Join Date
    Apr 2012
    Quote Originally Posted by xTiltx View Post
    I never realized the order of layers had such an effect.
    Yep, layers stack in Z space according to the order of the layers. I believe mouse input will also respond to the foremost object, so if there's a button underneath of another clip that is obscuring the hit area, it will not respond to mouse input.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

HTML5 Development Center

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.