White Flash frame when moving between levels
A Flash Developer Resource Site

Results 1 to 7 of 7

Thread: White Flash frame when moving between levels

  1. #1
    Junior Member
    Join Date
    Jan 2013
    Posts
    6

    White Flash frame when moving between levels

    HI all,

    This is my first post in the forum so i would like to say hi and thank you in-advance for any help!

    I am building a basic application with in Flash, witch it draws video files in and moves about different 'levels' with in the application.

    The problem i am having is that;

    The first page is on level '0'. you then move to the next area on level '1' draw a video in (on press of a button) this load on level '2', then to close the video, on press again, the area should load on level '0', this all works fine, but on the close of the video and the old area being placed, there is a white full screen flash, like some thing is refreshing.

    I managed to get rid of this but then i encountered different problem, such as the video not actually closing or the layer underneath changing to the wrong one.

    I dont know if this will make much sense when reading it. I am quite new to using flash but am having alot of problems with this,

    Thanks
    Elliott

  2. #2
    . fruitbeard's Avatar
    Join Date
    Oct 2011
    Posts
    970
    Hi,

    If you can attach your fla then we might be able to help after seeing it

  3. #3
    Junior Member
    Join Date
    Jan 2013
    Posts
    6
    Hey,

    Thats a problem, im signed in to an NDA so i can't. Ill try an write exactly what is going on. It will probably sound a bit backward the way i am doing it, but im not much of a Flash Artist so tried to do it as simple as i could.

    The main page that gets loaded on the web is called Index.html/fla/swf

    So there is a button on there that takes you to page2.swf via code;
    on (press){loadMovieNum("page2.swf",1)}
    loading the page on to 'layer' 1 and go to back to index there is a button with;
    on (press){loadMovieNum("index.swf",1)}
    on both pages there are buttons that on press loads an external video witch is embedded in a .swf so that it has some more interaction on it. This is done with this code;
    on (press){loadMovieNum("video1.swf",2)}
    Putting it on 'layer' 2.

    To close these videos there is a button with;
    on (press){loadMovieNum("index.swf",0)}
    or
    on (press){loadMovieNum("page2",0)}

    So all pages get loaded to layer 1, videos to layer 2 and then when they come out of a video it is reset to layer 0.

    I have kinda of sorted it now to the extent that the white flash ONLY happen's when;

    You go from index to page2, play a video and then close it, it flashes on the close, and the same from going from page2 to index and close a video, its only the first video on each player that gets the flash.

    I hope this helps and i'm open for any suggestions!

    Thanks
    Elliott

  4. #4
    . fruitbeard's Avatar
    Join Date
    Oct 2011
    Posts
    970
    Hi,

    I personally would load the movies to level 1 and always have something (even a static image!!) on level 0, the white happens due to there being nothing on level 0 between transitions (I believe).

  5. #5
    Junior Member
    Join Date
    Jan 2013
    Posts
    6
    How would i keep an image on level 0?
    I have tried a few things, having index and page move go to level 0 when they move between them, this then causes the white flash then going between pages. Having Index on level 0, page 1 on level 1 and the when you go back to index it loads it to level 1 also. But when you come off of a video (it takes you the page on level 1) but it then wont unload the video that is on level 2.

    Also. If i do all the above but keep the video on level 1. when you go on it, (the video page has transparency so you can see what is on the page under it) the underneath page flickers to the other if it is the first video on that page played.

    Thanks!!

  6. #6
    . fruitbeard's Avatar
    Join Date
    Oct 2011
    Posts
    970
    Hi,

    Sorry, I would need to see your file to help any further

  7. #7
    Junior Member
    Join Date
    Jan 2013
    Posts
    6
    Thanks for your help. I found a very simple bit of code that closes the layer.

    One thing that you might be able to help with. Im looking for a piece of code that will preload the FLVs when the first page is opened, so that there is less buffering time when the actual FLV files are opened.

    Thanks for all you help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width


HTML5 Development Center

Poll by Flashkit.com