Images and Thumbnails not loading in XML gallery when loaded in Flash Website?
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: Images and Thumbnails not loading in XML gallery when loaded in Flash Website?

  1. #1
    Junior Member
    Join Date
    Feb 2013
    Posts
    2

    Unhappy Images and Thumbnails not loading in XML gallery when loaded in Flash Website?

    Hi guys (and girls) =) I'm a budding web/flash designer. Hope everyone is nice here!

    Anyways, I'm going to copy and paste my question from the Adobe forums since I'm lazy, but don't be alarmed if you see it on another site. It is still not resolved. =(

    Here is my frustrating question:



    So I've had the time to continue working on my flash site. I already have the entire layout built in Flash.

    My site is built using timeline control scripts (AS3).

    Because I couldn't figure out how to make a scrolling gallery (I've looked everywhere and still do not understand), I proceeded to buy one on Activeden so I not only can use it, but could see how its done and learn from it. But the .fla file of the gallery is in AS2. The .swf is "self-contained" so Actionscript versions don't matter right?

    The gallery is XML based.


    I used this AS3 "loader" to load the .swf into my flash site.

    var myLoader:Loader = new Loader(); myLoader.contentLoaderInfo.addEventListener(Event. COMPLETE, showMySWF); function showMySWF(e:Event):void { addChild(myLoader); myLoader.x=100; myLoader.y=150; myLoader.contentLoaderInfo.removeEventListener(Eve nt.COMPLETE, showMySWF); } myLoader.load(new URLRequest( "xmlgallery.swf" ));

    All the images and assets are in the same folder as my flash site.

    But all I see is an empty gallery:

    Screen shot 2013-02-03 at 6.05.26 PM.png

    Where are the images? Do I need to import those in somehow even though they are already in the same folder?

    If I play the xmlgallery.swf file itself, all the images are there, but when I use the Loader to load it into my webpage, all the images are not. In other words, the gallery design itself is completely functional, but I just cannot see the thumbnails and images on it unless I test the xml gallery's own swf file. When I test my own flash site with the gallery loaded in, I see no photos; when I upload to a web server- nothing either and I tried 2 web servers.



    Thanks and I hope someone can give me some pointers (I've been staring at it for hours on end and for daysssss. The folks at Adobe's forums are really helpful, but most of them use advanced speak that I don't understand (for instance, one really nice guy suggested that I trace the script and I did but I don't even know what the outputted words mean)!

  2. #2
    :
    Join Date
    Dec 2002
    Posts
    3,517
    Sounds like the problem is using the AS2 swf loaded into the AS3 swf.

  3. #3
    Junior Member
    Join Date
    Feb 2013
    Posts
    2
    So would I need to convert the AS2 into AS3? I don't know enough about either versions to do this...what is the easiest way I could get this to work?

  4. #4
    :
    Join Date
    Dec 2002
    Posts
    3,517
    Yes, or try to find one that is already coded in AS3.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width


HTML5 Development Center

Poll by Flashkit.com