XML files and reading from cyrillic
A Flash Developer Resource Site

Results 1 to 7 of 7

Thread: XML files and reading from cyrillic

  1. #1
    Junior Member
    Join Date
    Mar 2013
    Posts
    3

    Question XML files and reading from cyrillic

    Hello, I want to start that I'm a newby in the Flash disigning. I created a Flash website and did the settings to take information for XML files, but I wrote the content of the XML files on cyrillic and when I loaded the website the information was missing. I saw some tutorials and Topics and change with Notepad C++ the encoding of the XML files to utf8 but that didn't work too. Then I continued to read in the internet and found that this line must be on my first line of all my XML files:

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    I change the encoding with utf8 but that didn't help too. Could you give me some advise what i shoud do to fix this problem. Thanks in advance and sorry for my bad English.

  2. #2
    Total Universe Mod jAQUAN's Avatar
    Join Date
    Jul 2000
    Location
    El Paso
    Posts
    2,429
    as long as you have a parent node for all your data you should be fine

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <root>
      <base1>
      </base1>
      <base2>
      </base2>
    </root>

  3. #3
    Junior Member
    Join Date
    Mar 2013
    Posts
    3
    jAQUAN, I cannot fully understand you, here is my code can you see it and tell me what exactry to change. Thanks in advance.

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
        <gallery wwidth="870" wheight="700" twidth="300" theight="300" vspacing="1" hspacing="1">
    
          <foto title="АВТОБИОГРАФИЯТА МИ(this is my cyrilic text)" thumb="img/bio/biografie1.jpg">
            <description>Я да пробваме така(this is my cyrilic text)</description>
    	</foto>
          <foto title="АПАРАТА С КОЙТО СНИМАМ(this is my cyrilic text)" thumb="img/bio/biografie2.jpg">
            <description></description>
    	</foto>
    
    </gallery>

  4. #4
    Dignitary rynoe's Avatar
    Join Date
    Jan 2003
    Location
    Earth
    Posts
    756
    Use CDATA (Character Data):

    Code:
    <![CDATA[АПАРАТА С КОЙТО СНИМАМ]]>
    and make sure you embed the full font.

  5. #5
    Senior Member realMakc's Avatar
    Join Date
    Oct 2002
    Posts
    677
    also, make sure it is actually utf8, and not just says so in <?xml encoding="" ?>

  6. #6
    Junior Member
    Join Date
    Mar 2013
    Posts
    3
    I added the CDAATA:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
        <gallery wwidth="870" wheight="700" twidth="300" theight="300" vspacing="1" hspacing="1">
    
          <foto title="BIOGRAPHY 1" thumb="img/bio/biografie1.jpg">
            <description><![CDATA[ПРОБААААААААА]]></description>
    	</foto>
    
          <foto title="ABOUT" thumb="img/bio/biografie2.jpg">
            <description><![CDATA[ПРОБААААА 22222222]]></description>
    	</foto>
    
    </gallery>
    but still not working only the "22222222" apeared in the box Any ideas, thx in advance.

  7. #7
    Dignitary rynoe's Avatar
    Join Date
    Jan 2003
    Location
    Earth
    Posts
    756
    Yep, your going to need to switch that to TLF text and manage it that way unfortunately. Which will mess with all your fonts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width


HTML5 Development Center

Poll by Flashkit.com