Buttons sometimes unresponsive on webpage (Adobe Flash cs5 action script 3.0)
A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: Buttons sometimes unresponsive on webpage (Adobe Flash cs5 action script 3.0)

  1. #1
    Junior Member
    Join Date
    Oct 2013
    Posts
    2

    Buttons sometimes unresponsive on webpage (Adobe Flash cs5 action script 3.0)

    Hi, my website is http://stephaniewright.myiadt.net/graphicdesigner/

    When the page first loads it goes to the home page and I only can click on gallery and about me. The rest of the buttons are unresponsive until I click on gallery and about me. Does anyone have any ideas why this is happening?

    My first frame on action script layer has: (corresponds to home on label layer)

    home_btn.addEventListener(MouseEvent.CLICK,goHome) ;

    function goHome(event:MouseEvent):void{
    gotoAndPlay("home");
    }

    second has: (corresponds to gallery on label layer)

    stop();



    gallery_btn.addEventListener(MouseEvent.CLICK,goGa llery);

    function goGallery(event:MouseEvent):void{
    gotoAndStop("gallery");
    }

    aboutme_btn.addEventListener(MouseEvent.CLICK,goAb outme);

    function goAboutme(event:MouseEvent):void{
    gotoAndPlay("aboutme");
    }

    third has: (corresponds to aboutme on label layer)

    nothing

    fourth has: (corresponds to resume on label layer)

    stop();

    resume_btn.addEventListener(MouseEvent.CLICK,goRes ume);

    function goResume(event:MouseEvent):void{
    gotoAndPlay("resume");
    }

    fifth has: (corresponds to contactme on label layer)

    stop();

    contactme_btn.addEventListener(MouseEvent.CLICK,go Contactme);

    function goContactme(event:MouseEvent):void{
    gotoAndPlay("contactme");
    }

    sixth has: (corresponds to testimonials, facebook, tumblr and twitter on label layer)

    stop();

    testimonials_btn.addEventListener(MouseEvent.CLICK ,goTestimonials);

    function goTestimonials(event:MouseEvent):void{
    gotoAndPlay("testimonials");
    }

    facebook.addEventListener(MouseEvent.CLICK, goFacebook);

    function goFacebook(event:MouseEvent):void
    {
    navigateToURL(new URLRequest("http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fstephaniewright.myiadt. net%2Fdesign230%2Funit5%2Findex.html&width=450&hei ght=80&colorscheme=light&layout=standard&action=li ke&show_faces=true&send=true&appId=12889289094")) ;
    }

    twitter.addEventListener(MouseEvent.CLICK, goTwitter);

    function goTwitter(event:MouseEvent):void
    {
    navigateToURL(new URLRequest("http://www.twitter.com/"));
    }

    tumblr.addEventListener(MouseEvent.CLICK, goTumblr);

    function goTumblr(event:MouseEvent):void
    {
    navigateToURL(new URLRequest("http://www.tumblr.com/"));

    }

    seventh has: (lines up with last frame of tumblr label on label layer)

    stop();




    Also it should be noted that on my labels layer in gallery label frame I have:

    stop();

    ga1.addEventListener(MouseEvent.CLICK,play1);
    function play1(event:MouseEvent):void{
    gotoAndPlay ("bedheadblonde")
    }
    ga2.addEventListener(MouseEvent.CLICK,play2);
    function play2(event:MouseEvent):void{
    gotoAndPlay ("gridwonderland")
    }
    ga3.addEventListener(MouseEvent.CLICK,play3);
    function play3(event:MouseEvent):void{
    gotoAndPlay ("shampoo")
    }
    ga4.addEventListener(MouseEvent.CLICK,play4);
    function play4(event:MouseEvent):void{
    gotoAndPlay ("bubbles")
    }
    gaa5.addEventListener(MouseEvent.CLICK,play5);
    function play5(event:MouseEvent):void{
    gotoAndPlay ("soap")
    }
    ga6.addEventListener(MouseEvent.CLICK,play6);
    function play6(event:MouseEvent):void{
    gotoAndPlay ("rob")
    }
    ga7.addEventListener(MouseEvent.CLICK,play7);
    function play7(event:MouseEvent):void{
    gotoAndPlay ("bookad")
    }
    ga8.addEventListener(MouseEvent.CLICK,play8);
    function play8(event:MouseEvent):void{
    gotoAndPlay ("crayon")
    }
    ga9.addEventListener(MouseEvent.CLICK,play9);
    function play9(event:MouseEvent):void{
    gotoAndPlay ("jaguarad")
    }
    ga10.addEventListener(MouseEvent.CLICK,play10);
    function play10(event:MouseEvent):void{
    gotoAndPlay ("m20poster")
    }
    ga11.addEventListener(MouseEvent.CLICK,play11);
    function play11(event:MouseEvent):void{
    gotoAndPlay ("bedheadred")
    }
    ga12.addEventListener(MouseEvent.CLICK,play12);
    function play12(event:MouseEvent):void{
    gotoAndPlay ("volkswagonad")
    }
    ga13.addEventListener(MouseEvent.CLICK,play13);
    function play13(event:MouseEvent):void{
    gotoAndPlay ("logos")
    }
    gaa14.addEventListener(MouseEvent.CLICK,play14);
    function play14(event:MouseEvent):void{
    gotoAndPlay ("arttext")
    }
    ga15.addEventListener(MouseEvent.CLICK,play15);
    function play15(event:MouseEvent):void{
    gotoAndPlay ("2panel")
    }
    ga16.addEventListener(MouseEvent.CLICK,play16);
    function play16(event:MouseEvent):void{
    gotoAndPlay ("gridfool")
    }
    gaa17.addEventListener(MouseEvent.CLICK,play17);
    function play17(event:MouseEvent):void{
    gotoAndPlay ("bathsalts")
    }



    That is the only code I have for this entire website.

    If anyone has any ideas, this issue is driving me nuts and I think somewhat effects functionality and usability of webpage.

    Thanks so much!

  2. #2
    . fruitbeard's Avatar
    Join Date
    Oct 2011
    Posts
    1,053
    Hi,

    Without seeing your file I think you might have a misplaced stop(); or two somewhere, hence stopping the movie before it reaches the button command code.
    It might be easier to diagnose if you could attach your fla or at least make a link to it, so we can look inside.

  3. #3
    Junior Member
    Join Date
    Oct 2013
    Posts
    2

    Hi

    Thanks so much for responding, I really appreciate it! Unfortunately, my FLA is too big to attach.

  4. #4
    Senior Member
    Join Date
    Nov 2012
    Posts
    106
    You must have resolved this, because the website buttons seem to be working now... I was going to guess, that the frame with the code and the frame with your buttons were not connected this should have thrown a Error #1009.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width


HTML5 Development Center

Poll by Flashkit.com