Custom Anti-Alias Text not animating in smoothly
A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: Custom Anti-Alias Text not animating in smoothly

  1. #1
    Junior Member
    Join Date
    Jun 2008
    Posts
    23

    Custom Anti-Alias Text not animating in smoothly

    I am having an issue with a font animating in from 0% - 100% smoothly. This issue is caused by it being custom anti-aliased, the font (Helvetica Neue-Light) has a slight thickness applied which it has to for font legability reasons. Due to file size restrictions I can't use a tween engine so can only use standard actionscript or tweening. I have tried both but neither works. I can't bitmap the text neither as it loses it's custom anti-aliasing.

    Any advice on how to resolve this would be much appreciated.

  2. #2
    . fruitbeard's Avatar
    Join Date
    Oct 2011
    Posts
    884
    Hi,

    Dies this help you at all, embed the font and try
    PHP Code:
    import mx.transitions.*;
    import mx.transitions.easing.*;

    myText.antiAliasType "advanced";

    var 
    fontTween = new Tween(myText"_alpha"None.easeNone01002true); 

  3. #3
    Junior Member
    Join Date
    Jun 2008
    Posts
    23
    Quote Originally Posted by fruitbeard View Post
    Hi,

    Dies this help you at all, embed the font and try
    PHP Code:
    import mx.transitions.*;
    import mx.transitions.easing.*;

    myText.antiAliasType "advanced";

    var 
    fontTween = new Tween(myText"_alpha"None.easeNone01002true); 
    Thanks for your help. This works in in the normal sense of fading text in. However the issue relates to a custom anti-alias being applied to a font, say the font being made thicker than normal. It still jumps on the final frame of fading in. I have had to cheat around this and place a graphic overlay on top of the static text and fade that out, thus bringing the text in without any glitch.

  4. #4
    . fruitbeard's Avatar
    Join Date
    Oct 2011
    Posts
    884
    Hi,

    Not sure if that meant you got it to work or not!
    Try attaching your fla or making a link to it, even a smaller file with the issue at hand.

    Maybe zip up the font too, as I'm not sure if I have the correct font, I have Helvetica Neue light, maybe different one though!!
    Last edited by fruitbeard; 10-02-2013 at 10:42 AM.

  5. #5
    Junior Member
    Join Date
    Jun 2008
    Posts
    23
    Quote Originally Posted by fruitbeard View Post
    Hi,

    Not sure if that meant you got it to work or not!
    Try attaching your fla or making a link to it, even a smaller file with the issue at hand.

    Maybe zip up the font too, as I'm not sure if I have the correct font, I have Helvetica Neue light, maybe different one though!!
    Thanks, but I 'have' resolved this. I found it easier to fade out a segment of background over the top of the text. The best solution would have been to use a tween engine such as greensock but due to file size restrictions I was unable to use this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width


HTML5 Development Center

Poll by Flashkit.com