PDA

Click to See Complete Forum and Search --> : sendAndLoad



siig
06-14-2001, 05:03 AM
Im trying to use sendAndLoad in flash 5. It works fine on my PC, but when I testet it on an other machine it doesnt load the XML... Why ???

Both pc's have flash 5 installed (5.0.42.0) and IE 5.5

Here is my flash code:
------------------------------------------------------------
onClipEvent (enterFrame) {
if (typeof (bMenuLoaded) == "undefined") {
oSendXML=new xml();
oSendXML.appendchild(oSendXML.createElement("test"));
oLoadXML = new XML();
oSendXML.sendAndLoad("test.asp", oLoadXML);
bMenuLoaded = false;
}
if (oLoadXML.loaded && bMenuLoaded != true) {
bMenuLoaded = true;
delete oSendXML;
_root.gotoAndPlay(2);
}
}
------------------------------------------------------------

On the not working test pc, the second "if" is never enteret, as if the oLoadXML never gets loaded but why?

Please help.....

VAYKENT
06-21-2001, 08:20 PM
How are your computers interacting with this test.asp?? Where is the file located? I'm thinking you migth have security issues....

Is the FLA located on both of the computers you're testing on?

siig
06-22-2001, 11:03 AM
Both the flash and the test.asp is located on a development server, which the both have acces to.

VAYKENT
06-22-2001, 11:19 AM
Where in the process is the second PC actually dying? Can you tell if the second PC is even activating the test.asp?

Your two test computers aren't in different domains are they?? You don't have domain security issues - do you?

Have you waited...and waited.... and waited.... for a response from the onLoad handler?? - or just said go and thought it didn't work?

I'm assuming that your test.asp is some kind of mirror?? It recieves something, and sends it back?? - or does it access a different XML file, and yuo've got problems there?

siig
06-22-2001, 11:23 AM
The second pc sends the xml to test.asp but it doesnt recieve any xml.

Both computers are on the same domain.

I have tried waiting for a long time but nothing happens.

The test.asp is responsibel for both recieving and sending xml-strings.

VAYKENT
06-22-2001, 11:27 AM
You've got me.. if the code runs on one PC, and not on another - but the two PC's are doing everything EXACTLY the same... AND have the exact same setup... then I don't know what to tell ya pal...