PDA

Click to See Complete Forum and Search --> : flash 5 font symbol shared library not working



superbox
07-06-2001, 03:48 AM
In Flash 5, there is this feature that supposedly allows you to use fonts from a Shared Library. This is documented in the technote http://www.macromedia.com/support/flash/ts/documents/sharedfonts.htm

BUT! I tried and tried and it still doesn't work! The static text in my movie is still embedding the fonts instead of drawing from the shared library, resulting in no smaller file size.

Any idea?

tone001
07-06-2001, 07:06 AM
Hmmm .... if i remember rightly yo create a new font symbol in the library ... then you have to give it a new name .... then you make sure all your text is using the new named font (from the library), not the old font (from your pc).

Is that what you are doing?

superbox
07-06-2001, 12:33 PM
yes, i did exactly that. it was an experiment. i wanted to see how it works, but it doesn't.

i created two swfs.

the first: fontlibrary.swf
new file, ctrl-L, click options, new font, name the symbol verdanafont, select verdana. linkage, export this symbol. save fla, publich swf.

the second: testfont.swf
new file, ctrl-L, open as shared library fontlibrary.fla
drag verdanafont to library of testfont.fla
text tool, select font *verdanafont (symbol fonts are marked with * so i cannot miss it).

DOESN'T WORK! the testfont.swf still embeds verdana!