PDA

Click to See Complete Forum and Search --> : Xml, send, sendAndLoad, asp



alveyd
07-09-2001, 04:21 PM
I am trying to pass an xml doc created in a Flash movie to an asp page in the same domain . However, when I use XML.send or XML.sendAndLoad, the asp page never gets displayed in the browser. Any ideas? Could I use the getURL method and Post the xmldoc as a variable?

Thanks
Davis
[Edited by alveyd on 07-09-2001 at 04:41 PM]

alveyd
07-09-2001, 06:02 PM
Ok. I fixed the problem. . .a stupid logic error elsewhere in the code. . .but not I am having trouble accessing the xmldoc that I Posted to the asp page.

Here is the (simplified) code in the asp page

Dim objXMLdoc, UserName

set objXMLdoc=Server.CreateObject("Msxml2.DOMDocument")
objXMLdoc.load(Request)
UserName=objXMLdoc.firstChild.nodeName
. . . .

it errors out on the UserName assignment line, giving me the error: Error Type:
Microsoft VBScript runtime (0x800A01A8)
Object required: '[object]'

Do I have to Declare 'UserName' as an xml object?

Any help would be greatly appreciated.

Davis

gerbick
07-10-2001, 01:52 AM
after you have done this, have you set the objXMLdoc to nothing after it is used? that may not help though...

I have some other questions... but without seeing the rest of the code, you could have an issue like I did... IIUSER did not have access to writing to the location I wanted the files were going... make it a virtual directory, and it will be ok... then again, I am not too sure what you are exactly trying to accomplish though.




Originally posted by alveyd
Ok. I fixed the problem. . .a stupid logic error elsewhere in the code. . .but not I am having trouble accessing the xmldoc that I Posted to the asp page.

Here is the (simplified) code in the asp page

Dim objXMLdoc, UserName

set objXMLdoc=Server.CreateObject("Msxml2.DOMDocument")
objXMLdoc.load(Request)
UserName=objXMLdoc.firstChild.nodeName
. . . .

it errors out on the UserName assignment line, giving me the error: Error Type:
Microsoft VBScript runtime (0x800A01A8)
Object required: '[object]'

Do I have to Declare 'UserName' as an xml object?

Any help would be greatly appreciated.

Davis