PDA

Click to See Complete Forum and Search --> : Combining Text with a Paint Element ?



NO CIRCUIT
09-18-2001, 11:02 PM
Hello
Thanks for stopping in I'm lost hope you can help ...

How do you add text to a paint element
that you just created

I want the text to follow and stay on the
paint element as I morph the paint element
thru different key positions

In other words does the egg come first
or the chicken.

I guess the text would be a child element
of the paint element or is it the opposite
or does it matter

Whats the easiest way to attach these 2 so
what ever actions are applied to one apply
to the other

Thanks in advance
Any feedback greatly appreciated

No Circuit

zoranvedek
09-19-2001, 12:25 AM
(edited because, as usual, I overlooked the obvious)

OK, I did a little trial and error this morning, and have come up with a much simpler way to add a text and paint object together. It's so simple, I feel like a fool for overlooking it in the first place.

Here it is............

Create a new layer, add the paint object, put the text on it, and then morph the entire layer.

Thats about as simple as I can get with it.

-Jason
[Edited by zoranvedek on 09-19-2001 at 06:37 AM]

NO CIRCUIT
09-19-2001, 09:40 PM
Hi Jason

That worked great thanks for the reply

But see if this happens to you

I did as you said and it worked perfect (almost)

I created a layer , added the paint element and the text

then I resized the text so it would fit nicely

within the paint element

Heres the problem

I added a fill color and played my movie in IFA

Worked out all the timining issues
Wolla it works perfect the paint element is blue
and the text is black and when I morph it they stay together
BUT
When I export the movie and upload it to the site
the fill color isnt there

Everything else works perfect

Except the fill color on the layers paint element
doesnt show up in browser

It shows up in black and white the outline and the text

I;m using IE 5.00.XXXXXXX because of other issues
they havent worked out in 5.5 namely the favorites folders
dont stay where you put them but thats a whole different story ...

Best Regards: No Circuit
[Edited by NO CIRCUIT on 09-19-2001 at 09:48 PM]

zoranvedek
09-19-2001, 11:59 PM
I've had similiar problems with morphing objects in general, what usually has happened is that you've changed the color after you've added the morph, for some reason the color change will not take effect.

I went ahead and made up an example, you can view it here...
---> http://members.aol.com/lucky13thday/movie_240.html

NO CIRCUIT
09-20-2001, 02:06 AM
Actually I created the layer

Added the paint element and color fill

Then I added the text element to the layer

Then I morphed it and played it in IFA

In IFA it plays with the color fill correctly

So I save it and then I export it

Then I up load it and when I go to the site

Theres no color fill

I tried adding a texture

and same thing plays correct in IFA

But when I up load and then go to site

No Dice

I'm hurtin ...

I downloaded the file from your site to examine the structure
Thanks for puttin it up
[Edited by NO CIRCUIT on 09-20-2001 at 02:08 AM]

NO CIRCUIT
09-21-2001, 12:19 AM
Ok just for the record
Originally
I created the layer
I copy and pasted the paint element in the layer
and then selected the fill color and clicked
on close the lines and fill with color
It did...
I then added the text I wanted to stay with the
paint element and resized it to fit the
paint element and when
I published it to the web
The paint outline and text was there but no fill color

So I tried it again this time
I created the layer
"Drew" the paint element (didnt copy and paste it in)
and filled it with the color
Then I added the text and sized it
and now it works ...
Go figure it was a paint element to begin with
that I coppied and pasted in the first place
on the same page but it wouldnt take the color fill

Must conquer flash animator (gasp)