PDA

Click to See Complete Forum and Search --> : Slight crashing problem



evolbeagle
10-29-2000, 12:07 PM
While working on my latest project I've had a slight crashing problem with KM. It always follows the same pattern.

I add a shape and decide I need to send it back a layer or two (but not to the very back). I send it back and it looks good in the staging area (or whatever you call the area where you create the movie). Then I play the movie in the stand alone player and the sent back item is still on top. Then I close the player and I immediately get a message that KM has performed and illegal operation and will be shut down.

This does not seem to happen when I send the shape to the very back and then bring it forward a few layers to put it where I want. (This is my work-around for the problem for now.)

Just in case this is unclear, here's an example:

Say I have 10 layers, with 1 at the bottom and 10 at the top. I want to put the most recently drawn shape, currently at layer 10, back to layer 7. If I use the send back feature to put it at 7 directly, the above crash problem occurs. If, on the other hand, I send it all the way back to 1 and then, in a separate step, bring it forward to 7, no crash.

I checked my system memory and it was not apparently the problem.

Is this a bug maybe? Or am I just lucky?

Bob Hartzell
10-29-2000, 03:04 PM
What version of the software are you using? Can you send me (bob@koolmoves.com) a zip of the .fun file and indicate which shape causes the problem.

evolbeagle
10-29-2000, 04:51 PM
I will. I've got to go out of town for a couple of days, but will email it to you when I return.

Also, I don't know the version right off, but I just downloaded and bought it last week if that helps.

I'll be more specific when I get back.

Thanks.

evolbeagle
11-06-2000, 09:45 AM
After repeated playing with KM yesterday, I could not reproduce the problem I was having last week either. (Bob had said in another post he could not reproduce the crashing problem I was having.) So, for now at least, it looks like that problem was a one-day thing. Maybe I wasn't holding my mouth right. If it happens again, I'll repost.

Bob Hartzell
11-06-2000, 11:38 AM
Please do send me a zip of the fun file if you are able to reproduce the problem. I depend on users to bring to my attention obscure bugs.

I will be issuing a new version probably Wed with a fix for a bug (press Up state button while already in up state) and import capability for .emf, .eps, and autocad .dxf. At that time it will be only about a week before I leave on vacation so I am making conservative changes to what appears to be a very stable version. Johnie, transparency of bitmaps will probably have to wait until after I return. It touches too many parts of the code.

For those that are interested, I am developing the capability to export Flash generator swt files. These files are very similar to swf files except for a few tags. This has strategic interest to us.

I expected to be further along by this time but such is software development.

BradBradleySL
11-06-2000, 12:00 PM
What ever happened to motion paths? Just curious, Bob did you check out my animation?

Brad

Bob Hartzell
11-06-2000, 02:32 PM
I have two chairs covered with little yellow post-its reminding me of what I need to do. Motion paths are one of those post-its.

Your animation gets better and better with each version.

johnie
11-06-2000, 06:02 PM
I'm not that familure with Shockwave Template files. Do you have a resource explaining them?

Bob Hartzell
11-06-2000, 07:35 PM
swt files are used by macromedia generator which allows parameterization of text, images, and sounds so web pages can be dynamically changed from a flash movie, a text file, a database, html, etc. You can read about generator on the macromedia web site. I know very little about it but I am gaining an appreciation of how powerful it is. An example is http://www.flashblaster.com -- swfs are generated on the fly from user input.