PDA

Click to See Complete Forum and Search --> : problems about "Using Sound in Flash Lite 1.1"



lawrencelee
10-13-2004, 11:09 PM
i have read the tutorial article named "Using Sound in Flash Lite 1.1" from Macromedia website, and followed the article to make a test file "blank_flashlite_sound_tests.fla". i tried the swf file on my desktop computer, only the forth(WAV) and the fifth(MP3) button work, the first three buttons are muted, so does the reference file "flashlite_sounds_tests.fla". Are these files normal?

and i tried to test it on the simulator of i-mode phone (http://tornado.cs.nccu.edu.tw/~lawrence/download/imodehtmlsim60pub_may0603.zip ), but there was an error message "Bad sound data error". i think the simulator is not compatible with the swf file. if so, where can i find a compatible simulator? :smoov:

mariamdh
10-14-2004, 01:36 AM
Hi,

What format of sound are you using for the first 3 buttons? Are you using pointers to midi/smaf/mfi sound on the desktop?

If you are using any of the above sound formats, then follow these instructions -
1. Save the midi/smaf/mfi files in a folder on your desktop.
2. Import a temporary wave/mp3 sound(a sound you won't be using) into your flash file.
3. Open the sound properties of the wave/mp3 sound from the library. You will find an option called device sound. Select a midi/smaf/mfi file you want to use from the folder you you created earlier.
That wave/mp3 file will now act as a pointer to the midi/smaf/mfi file on your machine. This is done since these sound formats cannot be imported into flash.

What could be happening in your case is, either the swf is not able to locate the device sound, or the flash lite player on your machine is not updated. This is a link to the updated file -
Updater to 7.0.1 for Flash MX 2004 and Flash MX Professional 2004 (English) (http://download.macromedia.com/pub/flash/updates/mx2004/update_fmx_2004.exe)

Let me know if this works.

Mariam Dholkawala

lawrencelee
10-14-2004, 11:22 AM
mid, fls(FlashLite Sound Boundler) and kar.

i tried to import a wave file in a testMfi.fla and had a button activated the wave file, and set the device sound to point to a mfi(.mld) file. i published it to generate test01.swf under two conditions: flash7 and flashlite 1.1. for flash7, it works with the wave sound. for flashlite 1.1 (i use a i-mode simulator to simulate a device), it is muted. obviously the mfi file is not well-pointed.

the .fla file
http://tornado.cs.nccu.edu.tw/~lawrence/download/testMfi.fla

the i-mode simulator
http://tornado.cs.nccu.edu.tw/~lawrence/download/imodehtmlsim60pub_may0603.zip

mmdev
10-14-2004, 11:46 AM
Lawrence,

Sound bundling was is one of the new features of Flash Lite 1.1. I'm not sure if the simulator or even the latest Flash-capable i-mode phones support Flash Lite 1.1.

Good luck,
Nader Nejat // Multimedia Consultant + Developer
OmegaMedia // http://www.omegamedia.com
"We help people take advantage of interactive media"

lawrencelee
10-15-2004, 05:28 AM
Could you suggest me a cell phone simulator for flash lite 1.1?
i've tried since many weeks ago, but i couldn't find any...

thank you:P:)

hp3
10-15-2004, 09:38 AM
Can the imode simulator diplay a SWF that only contains graphics and no sound?