PDA

Click to See Complete Forum and Search --> : Newbie: Creating a photo Blog? Where to Start?



asun2art
09-23-2005, 03:17 PM
Any sites, links? advice? i have no idea how to go about this...

WannaBe_80z
09-23-2005, 03:19 PM
I use www.pixelpost.org and I modified the template "Light_white"

http://s92349618.onlinehome.us/pixelpost_1.4.2/index.php

Still tweaking as I go

EVPohovich
09-23-2005, 03:34 PM
folderblog.com

WannaBe_80z
09-23-2005, 03:38 PM
Is that what you use? I looked into that before someone told me about pixelpost...PP seemed easier to setup and control

to each their own

EVPohovich
09-23-2005, 03:55 PM
Yeah, mine is a heavily modified version of folderblog. It, closer than anything else, matched what I wanted to do and then I just added fro there.

asun2art
09-23-2005, 04:49 PM
So a photoblog is just a script or template you download and modify and host on your own domain?

aversion
09-23-2005, 05:09 PM
I built my own system, I didn't like the blog options when I started, though now there are more specialist photoblog ones, they used to just be bastardised text blog systems. If you know PHP/MySQL or similar it's not too hard, just two tables, one for images and one for comments, then a few web forms.

I hear pixelpost is good.

ctranter
09-23-2005, 06:40 PM
pixelpost works well for me

nordberg
09-23-2005, 09:53 PM
i use pixel post as well. easy to set up, easy to modify.

tonytryout
09-24-2005, 07:28 AM
Just downloaded OneReaction PhotoBlog (in ASP.NET) -- it is supposed to be good. I will let you know what it is like as soon as it is on the server.

asun2art
10-07-2005, 01:33 PM
Do you pay for these or are they free? I see some of the popular Photo Blogs are pimping templates/software that costs around $50-60.

ctranter
10-07-2005, 01:43 PM
pixelpost is free, not sure about others.

tonytryout
10-07-2005, 03:38 PM
OneReaction is free but have not managed to get it working on a .NET server (due to my lack of experience with .NET)

magritte
12-07-2005, 11:01 AM
do you know other programe(can be paid) as folderblog ,poxelpost,porta simple viewer but without the logos by.....

robbmcaulay
12-07-2005, 11:43 AM
You can remove any 'pixelpost' refrences from pixelpost if you must...

littleMatt
03-16-2007, 04:07 PM
Right! Sick to the back teeth of spending hours and hours adding a small amount of images and thumbnails to my photoblog!

From this thread I've looked at pixelpost & folderblog (both seem to have the look and functionality I'm after) but due to how complicated they seem I don't think either will be an option.

Can anyone suggest anything that will look good, have all the comments/archive jazz but most importantly be do-able buy someone who is completely ignant to PHP and mySql etc??

Any suggestion or am I doomed? :)

WannaBe_80z
03-16-2007, 04:16 PM
For pixelpost all you do is put the folder on your site and then it does all the sql stuff for you. As far a php goes to visually change the look all you really need to do is edit the css file and as long as you know basic programming(html etc) you should easily be able to do what you want. If i can do it anyone can.

littleMatt
03-16-2007, 04:32 PM
Hmmm... I reckon I could get my head around the CSS but when I upload the folder to my site it says this:


You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.

david petley
03-16-2007, 05:58 PM
Matt, have you spent some time with pixelpost's wiki? You might get some clues on installation and PHP/MySQL error messages -
http://wiki.pixelpost.org/index.php?title=Main_Page

david

WannaBe_80z
03-16-2007, 06:26 PM
do you have all the folder permissions set to read AND write?

littleMatt
03-16-2007, 06:36 PM
No, looking at the wiki I don't think I have access to what I need access to. Even if I did I still wouldn't know what I was doing...

I'll ask my host what's possible with my service on Monday, hopefully that will shed some light :)

1stbite
03-16-2007, 06:37 PM
Own hosting:
pixelpost

free bandwidth and system (one pic a day system):
http://www.aminus3.com/

robbmcaulay
03-16-2007, 07:04 PM
littleMatt, who provides your hosting and what package do you get?

I want to get this sorted for you because once installed it's a piece of piss to work!

All you really need is access to phpmyadmin to create the database and some sort of online file manager to set permissions on the right folders.

littleMatt
03-16-2007, 07:17 PM
A mate of a mate does my hosting - not sure of the package other than I have unlimited storage space. He said that I would have access to MySQL and MS Sql Server databases... ??

littleMatt
03-19-2007, 05:46 PM
OK I'm getting somewhere, kinda:


Let's see if we can save images in the folder images:

Images folder is writable, which is a good thing.

Let's see if we can save thumbnails in the folder thumbnails:

Thumbnails folder is writable.

Next thing you want to do is login to the admin interface and get started posting.

Pixelpost does not come with any warranties. Let's hope it'll work great for you and give you a worryfree great photoblog.

But when I try to login to the admin interface the page cannot be found. Tried in a different browser. Is there something really silly I'm doing wrong?

Edit: Sorry should have said before all that that my host set me up with the mySQL thing and this is how far I've got into it.

littleMatt
03-19-2007, 06:00 PM
On the admin/index.php page it says:


Notice: Undefined index: view in D:\home\Managed Websites\fishandonions.co.uk\htdocs\pixelpost\incl udes\functions.php on line 512

Notice: Undefined variable: pinglist in D:\home\Managed Websites\fishandonions.co.uk\htdocs\pixelpost\addo ns\admin_ping.php on line 108

Notice: Undefined index: x in D:\home\Managed Websites\fishandonions.co.uk\htdocs\pixelpost\admi n\pass_recovery.php on line 8

Notice: Undefined index: pp_user in D:\home\Managed Websites\fishandonions.co.uk\htdocs\pixelpost\admi n\index.php on line 128

Notice: Undefined index: x in D:\home\Managed Websites\fishandonions.co.uk\htdocs\pixelpost\admi n\index.php on line 136

Notice: Undefined index: x in D:\home\Managed Websites\fishandonions.co.uk\htdocs\pixelpost\admi n\index.php on line 160

Notice: Undefined index: view in D:\home\Managed Websites\fishandonions.co.uk\htdocs\pixelpost\incl udes\functions.php on line 484

Notice: Undefined index: view in D:\home\Managed Websites\fishandonions.co.uk\htdocs\pixelpost\addo ns\admin_12CropImage.php on line 82


Does this mean anything?

1stbite
03-19-2007, 08:22 PM
did you edited a config file on setup?

are you able to login even with the errors displayng?

littleMatt
03-19-2007, 08:30 PM
Yes I entered my database name/user/pass etc into the pixelpost.php and the instillation seemed alright - I set an admin username and pass. Then it gave me the "Next thing you want to do is login to the admin interface and get started posting." message which led nowhere...

I don't know if it's related but the wiki said I should change the ownerships and permissions on the 'thumbnail' & 'images' folders to 777 - but when I try I get the message: "Fetch could not set permissions for "thumbnails" because the FTP server sent an unexpected response"

Sorry, I'm seriously clueless with all this lot :(

littleMatt
03-20-2007, 08:41 AM
OK - sorry to be filling this thread up with useless text - the problem was fixed by my host (some error that end)

It now seems to work fine: http://www.fishandonions.co.uk/pixelpost/

So all I have to do is transfer the some 300 pictures from the old site to the new one :D

E, feel free to delete the my useless posts from above

I really appreciate all the help from everyone :)

1stbite
03-20-2007, 03:05 PM
...the problem was fixed by my host (some error that end)


That was me next port of call if editing the configuration right and able to login, it probably was the error logging variable in the php.ini (server admin access only) was set to E_ALL to show all errors which is useful for debugging but as you noticed damn messy in real world situations ;) .

littleMatt
03-20-2007, 03:48 PM
Yeah that's what he said.

took me about 5 hours of googling before I asked for his help - it took him 5 minutes to fix :D D'Oh!

robbmcaulay
03-20-2007, 10:09 PM
So all I have to do is transfer the some 300 pictures from the old site to the new one :D
*cough* and get a new theme *cough* :D

Glad you got it all up and running! It's a piece of piss to use from now on...

littleMatt
03-21-2007, 11:57 AM
hehe! Now that it's working I'm scared to touch in-case I break it!

What's happened to your site by the way??

robbmcaulay
03-21-2007, 12:05 PM
**** knows...

[edit] I just phoned... this is their excuse http://switchboard.homepageuniverse.com/switchboard/blog/2344:H3_hard_drive_errors

:D