PDA

Click to See Complete Forum and Search --> : Loading external .swf sound files not controllable



dwilliam
07-05-2000, 01:17 AM
desire: better control different sound loops when a user selects a button to go a different scene. also to break down the combined .swf movie into smaller chunks for better downloading speed and to more specifically manage the timing of downloads of different sounds before playing them

problem: can't get frame actions or button actions to control the external .swf sound files. see scenarios

- basic scenario - want to load sound.swf at frame 20 of main.swf but not begin playing.

First attempt
.....at frame 20 of main movie
Load Movie ("sound.swf", 1)
Tell Target ("_level1")
Stop all sounds
End Tell Target
(sound.swf frame 1 includes the sound loop)

Result: Movie gets to frame 20 and begins playing sound.swf (DAD gon 'it)

Second attempt
......at frame 20 of main movie
Load Movie ("sound.swf", 1)
Tell Target ("_level1")
Go to Stop (1)
End Tell Target
......at frame 1 of sound.swf
Stop all Sounds
Stop
......at frame 2 includes the sound

Result: Movie gets to frame 20 and stops All sounds that were playing before it (GEE Whitakers)

Any takers on this one??

Thankee

daflash
07-05-2000, 02:03 AM
hope I understand this correctly if so here is what I would do. I would put 2 keyframs in sound.swf and in the first keyframe I would just put a "STOP" action and in the second keyframe I would put my sounds and set them to event. Then in my main movie I would put in a keyframe the action to load sound.swf and I would make a button that when pressed would advanced the playhead on sound.swf from the first keyframe to the second keyframe where at such time the sound would play in sounds.swf you can add a "STOP action to the second keyframe in sounds.swf if you need it but that does not seem to be what you were asking so I will leave that up to you. Hope that helps.
http://board.flashkit.com/board/

dwilliam
07-05-2000, 09:15 PM
I tried that but it works only sometimes.

For example I have a button on scene 2 that Tell targets _level3 with the sound for that scene and Go To 1 where it stops (sound is on 2). But when I publish the movie and test it, it works only part of the time.

Also, the sound doesn't psynch up to the animation. In fact, the movie actually runs slower when I load the movie on another clip besides the main timeline ie., MC or _level1+

jydnas
07-05-2000, 11:27 PM
i have not had any problems so
i don't know what to tell you except

at frame 20 use Load Movie ("music1.swf"1)

then in the music1.swf

make two layers
1 named music
2 named action

in frame 1 of the layer named actions
put the stop action
in frame 1 of the layer named music
add the music except
in the SYNC box select STOP
in the 2 frame of the layer named music
add a key frame and add the music only this time in the SYNC
box select START.


now it will load but not play
until you make a button that
ON Press
Begin Tell Target ("_level1")
Go To And Play Frame (2)
End On