PDA

Click to See Complete Forum and Search --> : CSS problems w/ FF on backgrounds



ced--ced
12-21-2006, 08:16 AM
Hi,

I have the following CSS code:

body {font-size: 1px; background-color:CAB69D; font-family: Verdana, Arial, Helvetica, sans-serif;background-image:url(images/pancho.jpg); background-repeat:no-repeat; background-position:top right; background-attachment:fixed; background-color:#CAB69D; scrollbar-arrow-color:#C00000; scrollbar-Track-Color:#CAB69D; scrollbar-Highlight-Color:#CAB69D; scrollbar-base-color:#CAB69D; scrollbar-Face-Color:#CAB69D; scrollbar-Shadow-Color:#C00000; scrollbar-DarkShadow-Color:#CAB69D;}

.nametext{margin-top: 0px;width: 300px; height: 50px; background-image:url(images/logo.jpg); background-repeat: no-repeat; font-size: 1px; text-align:center;}

My problem is on the two underlined elements. Surpringly Firefox doesn't render the body bgd colour and the bgd image in the nametext.

Any thougth on that?

Thanks

aversion
12-21-2006, 09:14 AM
There's no '#' before your colour hex in the body definition. Not sure if that's an actual typo or just a post mistake. IE might ignore that but FF might not.

jasonsplace
12-21-2006, 12:01 PM
Also, is there a reason that you have the background color twice in the body section. You should clean that code up a bit.


body {
font-size: 1px;
font-family: Verdana, Arial, Helvetica, sans-serif;
background: #CAB69D url(images/pancho.jpg) no-repeat top right fixed; scrollbar-arrow-color:#C00000;
scrollbar-Track-Color:#CAB69D;
scrollbar-Highlight-Color:#CAB69D;
scrollbar-base-color:#CAB69D;
scrollbar-Face-Color:#CAB69D;
scrollbar-Shadow-Color:#C00000;
scrollbar-DarkShadow-Color:#CAB69D;
}

.nametext{
margin-top: 0;
width: 300px;
height: 50px;
background:url(images/logo.jpg) no-repeat;
font-size: 1px;
text-align:center;
}

blandis
12-22-2006, 04:22 PM
I am having the same problem with Firefox not showing my background image.

Please let me know if you know what is up.

Thanks,
Brian

jasonsplace
12-22-2006, 04:24 PM
Can you provide a link? It's hard to see what's going on without seeing the problem.

blandis
12-22-2006, 04:31 PM
This site just a layout for the home page which is very incomplete, but if you look at it in IE it looks much closer to actually working properly. FF does not show the background image in the main content area for some reason.

http://www.capitalwebtec.com/clients/kls/template.htm

Thanks in advance for looking at it.
Brian

ced--ced
12-22-2006, 05:18 PM
I have the body background color sorted now, but not the text background yet.

I have the text set at 1px, basically because I can't remove it and want to replace it with a picture. It's in fact the name component on myspace. I have noticed that when I enlarged the text, the background started to show up! I haven't look at it properly yet but will let you know.