PDA

Click to See Complete Forum and Search --> : Displaying 100% w/h in Firefox & Netscape 8



davidhannes
02-10-2007, 03:55 PM
This one is frustrating.

Such a suimple task. Make my .swf file streach to fit 100% w and 100% so it fills the window.

If IE it works fine, in Firefox and Netscape 8 My .swf comes out to be a shrunken version of itself. WTF?

Any help is appreciated. I am stumped.

Here's the page live: http://www.develop4u.com/v2/frameset_webdesign.htm

Below is my source code:

--------------------------------------------------------------------------
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 FINAL//EN">

<HTML>

<HEAD>



<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">



<TITLE>Web Design</TITLE>

<!-- Master script -->

<META NAME="description" CONTENT="A cutting-edge multi-media company, Creative Developments offers clients a wide variety of services including web design, e-commerce, Flash animation, digital art, illustration, advertising, photographic retouching, and graphic design.">





<META NAME="keywords" CONTENT="David Hannes, Creative Developments, e-commerce, web design, web, graphic, animation, multi-media, Flash, art, illustration, advertising, retouching, Photoshop, Dave Hannes, creative developments">
<link rel="stylesheet" href="cd_text.css" type="text/css">
<script type="text/javascript" src="swfobject.js"></script>
<link href="../cd_text.css" rel="stylesheet" type="text/css">
<link href="../fontsize.css" rel="stylesheet" type="text/css">

<script src="../scripts/AC_RunActiveContent.js" language="JavaScript" type="text/javascript"></script>
<script src="../scripts/AC_Flash.js" language="JavaScript" type="text/javascript"></script>
<style type="text/css">
<!--

body, html {
margin: 0;
padding: 0;
height: 100%;
width: 100%;
}

body,td,th {
color: FFFF00;
}
body {
background-color: #000000;
}
a:link {
color: #00FFFF;
}
a:visited {
color: #00FFFF;
}
a:hover {
color: #FFFF00;
}
a:active {
color: #FFFF00;
}
-->
</style>




</HEAD>

<BODY>
<!-- Start of the Body for this Page -->

<!-- Master Body script -->

<table width="100%" border="0" cellspacing="0" cellpadding="0" height="100%">
<tr>
<td align="center" height="*" valign="middle" width="100%" >




<div align="center">

<noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="100%" height="100%">
<param name="movie" value="frameset_webdesign5.swf">
<param name="quality" value="high">
<embed src="frameset_webdesign5.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="100%" height="100%"></embed>
</object></noscript>
<script language="JavaScript" type="text/javascript" >
<!--
AC_RunFlContentX ("movie", "frameset_webdesign5", "quality", "high", "src", "assets/intro_cd_WHITE", "width", "100%", "height", "100%" );
//-->
</script>
</div></td>
</tr>
</table>

</BODY>

</HTML>

Cemrin
02-10-2007, 04:14 PM
One thing I suggest, although this may not totally fix things, is to use a more recent Document Type Definition, such as HTML 4.01.

HTML 3.2 is terribly outdated, and contains many problems which can lead to improper display for different browsers.

If you want to use the HTML 4.01 Doctype, copy it from here:



<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">