A Flash Developer Resource Site

Results 1 to 4 of 4

Thread: loadVariables w/ CGI doesn't work on server

  1. #1
    Senior Member
    Join Date
    Jun 2001
    Posts
    267

    loadVariables w/ CGI doesn't work on server

    I have a form that submits 4 variables to a cgi script to be written to a database. I know the flash and cgi work, because I can run it locally and have it submit to the database. (I open it from the desktop into a browser and it communicates with the CGI script on the server and writes to the server database). I am running Flash 5 on a Mac. We have tried the same FLA published from a PC--same problem.

    HERE IS THE PROBLEM
    If I upload the exact same files to our server nothing is written to the database when the game is finished.

    Specs:
    Here's the code I am using to send it:
    loadVariables ("http://www.saltlake.org/cgi-bin/downhill.cgi", "", "POST");

    The game resides at:
    http://www.saltlake.org/game-submit/ski-game-form.html

    or

    http://www.visitsaltlake.com/game-su...game-form.html
    (saltlake.org and visitsaltlake.com have the same IP address)

    Copies of the swf, fla, and cgi are available if you need them. Please let me know. I really appreciate any help you can offer.

  2. #2
    Registered User
    Join Date
    Feb 2001
    Posts
    13,044
    Hi,

    the movie at saltlake.org is actually sending data to the script (but there is no response) so it could be a problem with the script or with, e.g., database passwords. Maybe it just does not like my confirmation number...

    The movie at visitsaltlake.com cannot send to the script at saltlake.org even if it is the same server - you should make arrangements that you can reach the script with a visitsaltlake.com address as well.

    If you want me to look at the cgi, please attach to your post or contact me via board email

    Musicman

  3. #3
    Senior Member
    Join Date
    Jun 2001
    Posts
    267
    If what you are saying is the case, why does it work with the cgi on the server when it is played from the desktop? Also, how do you know the movie is sending data to the script but with no response?

    The only verification on the submitted info is if there is something in the field. So it doesn't not like the confirmation.

    Also, it is not DB passwords becuase the DB is used for alot of other things on our site.

    I will send the cgi along via board-mail.

  4. #4
    Senior Member
    Join Date
    Jun 2001
    Posts
    267
    Hallelujah! The problem is fixed. Thanks to musicman for the confirmation that it won't work from visitsaltlake.com--I was having a hard time convincing my boss of that,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center