A Flash Developer Resource Site

Page 1 of 2 12 LastLast
Results 1 to 20 of 23

Thread: e-mail sending

  1. #1
    Senior Member
    Join Date
    Feb 2002
    Location
    Geneva, CH, Europe
    Posts
    521
    I have tried the "e-mail in Flash the easy way" tutorial (http://www.flashkit.com/tutorials/Dynamic_Content/E-mail_i-Jeffrey_-658/index.shtml) with PHP. Somehow it doesn't seem to work, and I really don't know why!!
    Can anybody help? i know that there is no source file to study, but I will send them to you if you want, as i don'tknow where to post PHP and FLA files.

    So please help...

  2. #2
    Now listen heah! Mac8myPC's Avatar
    Join Date
    Aug 2000
    Location
    Steve Job's Doorstep
    Posts
    695
    how long is your php code? could you post it here? - the flash side should just be a form with a submit button.... let me see your php first and we'll see if maybe there's something in there we can fix

  3. #3
    Registered User
    Join Date
    Feb 2001
    Posts
    13,044
    Hi,

    there should be sort of a checklist / troubleshooting guide...
    a) make sure that the varnames in the flash form and in the mailscript match (case-sensitive)
    b) try to open the mail script from the browser, e.g.
    http://yoursite.com/snowmail.php?Nam...mail=me@me.com
    using the same vars as in the form and script.
    Do you get an error message or perhaps all of the php code in the browser, or do you receive mail?
    If there is an error message, try to fix the php (Hint: parse error on line ... often means that the last code line before the one mentioned does not end in a semicolon)
    c) if your server runs php 4.1 or later, chances are that you have to change the script a bit

    If you get an error message you dont understand, post it here. lso, every now and then problems can be diagnosed if you post a link to your flash form

    Musicman

  4. #4
    Senior Member
    Join Date
    Aug 2000
    Posts
    309
    you could check out my example if that helps. maybe something in the fla will trigger something 4 u.

    it's only F5 - not MX though.

    goto : http://user:pass@www.bigjolt.com/lab/php_mailer

    cya
    henry
    [Edited by BIG jolt on 06-03-2002 at 12:15 AM]

  5. #5
    Senior Member
    Join Date
    Feb 2002
    Location
    Geneva, CH, Europe
    Posts
    521
    Thanks a lot everbody!!

    There are some two or three questions I have, though :
    1. BigJolt, your URL is not working.

    The next question is a very very very newbie one : I don't have a PHP server on my PC. Does it work???

    Thanks for the reply...

  6. #6
    Senior Member
    Join Date
    Aug 2000
    Posts
    309
    hmmm - worked here - ns4.7 and ie5.5 on a pc

    try it with a manual log-in - goto:

    http://www.bigjolt.com/lab/php_mailer - then log-in with username = user and password = pass

    you need to have at least php on your machine or your webserver.

    my tip - spend a little time setting up a webserver on your local machine - it's well worth the effort. go for this combination - apache, php, mysql at the least.

    search around for an installer. phptriad used to be good but is now unsupported. maybe check http://www.hotscripts/php for another installer.

    the alternative is to install the 3 components manually. getting the paths and .ini files right can be a bit fiddly though.

    cya
    henry




  7. #7
    Junior Member
    Join Date
    Jan 2001
    Posts
    16
    bigbolts, i also developing the phpmailer but i can't send mail from my "localhost".
    my code is like this:
    mail("XXXX@domain.com","Subject","Body");
    but it couldn't work n display "Warning: Server Error"
    pls help. thanks

  8. #8
    Junior Member
    Join Date
    Jan 2001
    Posts
    16
    sorry for wrong typing your name, big jolt^^

  9. #9
    Senior Member
    Join Date
    Aug 2000
    Posts
    309
    lol ... sing cheng ... just like frankenstein ...

    yep that is how you use mail () - eg:

    Code:
    <?php
    
    mail(" singcheng_koh@hotmail.com","the subject","my_message","From: bigjolt@bigjolt.com");
    
    ?>
    if it is not working make sure - you have the mail SMTP setup in your php.ini file properly. the SMTP value is usually your ISP mail server.

    cya
    Henry


  10. #10
    Junior Member
    Join Date
    Jan 2001
    Posts
    16
    big jolt,
    what is needed in order to setup my PC into a mail server?
    os: XP pro, IIS 5.1

  11. #11
    Senior Member
    Join Date
    Aug 2000
    Posts
    309
    not sure about a mail server sing. i use my isp's mail server for all testing of mail handling. i run apache, mysql and php on my win98 machine.

    i see you have iis running - do you have php installed?

    if you do then, check your php.ini file.

    if not, then check http://www.php.net/downloads.php - choose the php4.2.1 installer and download it. it auto installs for iis.

    give it ago! good luck

    cya
    Henry


  12. #12
    Senior Member
    Join Date
    Feb 2002
    Location
    Geneva, CH, Europe
    Posts
    521
    I've got a small problem with PHPtriad. I installed it a few weeks ago and as Big JOLT said it was not very good, I wanted to uninstall.

    But how in the world do you do it? There's no uninstaller integrated, and it doesn't exist in the ADD/Remove programs list!!

  13. #13
    Senior Member
    Join Date
    Aug 2000
    Posts
    309
    sure there is not an UNinstaller.

    i downloaded phptriad 2-2-1 the other night and installed it just to have a look during a process of upgrading my version of php.

    the install made a real mess of my existing settings - ie .ini files but I was able to recover.

    it should make a phptriad folder on c:\ drive. the versions of php and mysql that it installs are within that directory.

    i'm sure i used add/remove programs from the win control panel to remove it.

    cheers
    Henry



  14. #14
    Senior Member
    Join Date
    Aug 2001
    Posts
    161
    i am having the same problem with my mail script as sing cheng. if anyone has figured out how to fix this annoying little problem.

    thanks much

  15. #15
    Senior Member
    Join Date
    Feb 2002
    Location
    Geneva, CH, Europe
    Posts
    521
    If you did it thru control panel, could you please give the name of the program, because I still can't find it.

    Thanks

  16. #16
    Senior Member
    Join Date
    Aug 2000
    Posts
    309
    if you're not able to find the phptriad uninstaller, maybe look for apache, php and mysql and uninstall all the individual applications.

    what trouble are you having with phptriad btw - not working properly? php not running?

    Cya









  17. #17
    Senior Member
    Join Date
    Jun 2000
    Posts
    687
    Here try this:

    http://www.flashkit.com/tutorials/Ba...76/index.shtml
    (installing PHP, MySQL, Apache, PHPmyAdmin manually)

    If you have any trouble post back to this board - hopefully you can get through it.

  18. #18
    Senior Member
    Join Date
    Feb 2002
    Location
    Geneva, CH, Europe
    Posts
    521
    Ok great thanks!

    PHP not working withPHPtriad

  19. #19
    Junior Member
    Join Date
    Apr 2005
    Location
    South Florida
    Posts
    9
    Hopefully somebody can help me. I am using the phpMailer created by BigJolt and I am able to send everything properly when I test it on my computer. But, when I upload the .swf file to my website, it doesn't go through. I get no confirmation email or detail email. Has anybody had this problem before?

  20. #20
    Registered User
    Join Date
    Feb 2001
    Posts
    13,044
    Hi,

    a) bigjolt's code is old ... it could be that it does rely on register globals
    b) would you mind to post a link to the form?

    Musicman

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center