A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: Adding an auto play button to my movie

Threaded View

  1. #1
    Registered User
    Join Date
    May 2002
    Posts
    171

    Adding an auto play button to my movie

    Hi all,
    I'm having great difficulty with the following.
    I'm using the following actionscript:
    Code:
    images_xml = new XML();
    images_xml.onLoad = startImageViewer;
    images_xml.load("xml/images.xml");
    images_xml.ignoreWhite = true;
    
    function startImageViewer(success) {
        if (success == true) {
            rootNode = images_xml.firstChild;
            totalImages = rootNode.childNodes.length;
            firstImageNode = rootNode.firstChild;
            currentImageNode = firstImageNode;
            currentIndex = 1;
            updateImage(firstImageNode);
        }
    }
    
    function updateImage(newImageNode) {
        
        imagePath = newImageNode.attributes.jpegURL;
        imageText = newImageNode.firstChild.nodeValue;
        targetClip.loadMovie(imagePath);
        
    }
     
    next_btn.onRelease = function() {
        nextImageNode = currentImageNode.nextSibling;
        if (nextImageNode == null) {
            break;
        } else {
            currentIndex++;
            updateImage(nextImageNode);
            currentImageNode = nextImageNode;
        }
    };
    
    back_btn.onRelease = function() {
        previousImageNode = currentImageNode.previousSibling;
        if (previousImageNode == null) {
            break;
        } else {
            currentIndex--;
            currentImageNode = previousImageNode;
            updateImage(previousImageNode);
        }
    };
    What i want to do is add another button called "auto_play", this button when clicked will display the image that is currently being displayed (from the xml file) for 20 seconds then move on to the next image from the xml file and display that for 20 seconds and so on until it gets to the last image in the xml file.
    Also, when the "auto_play" button is clicked again it will turn this feature off and display from where it is in the xml iamge list.

    Here is the xml file:

    PHP Code:
    <?xml version="1.0"?>

    <IMAGES>


    <imageNode jpegURL="images/pic_1.swf">
    </imageNode>
    <imageNode jpegURL="images/pic_2.swf">
    </imageNode>
    <imageNode jpegURL="images/pic_3.swf">
    </imageNode>
    <imageNode jpegURL="images/pic_4.swf">
    </imageNode>
    <imageNode jpegURL="images/pic_5.swf">
    </imageNode>
    <imageNode jpegURL="images/pic_6.swf">
    </imageNode>
    <imageNode jpegURL="images/pic_7.swf">
    </imageNode>
    <imageNode jpegURL="images/pic_8.swf">
    </imageNode>
    <imageNode jpegURL="images/pic_9.swf">
    </imageNode>


    </IMAGES>

    Any help on this issue would be greatly appreciated.

    Regards,
    Suzy
    Last edited by suzy_Q; 03-18-2003 at 08:54 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center