A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: Problems with scenes

Hybrid View

  1. #1
    Member
    Join Date
    May 2000
    Posts
    34

    Problems with scenes

    I am having a problem were I created a movie & there are 5 scenes. Everything works perfectly except when I click the button that takes you to the last scene. Instead it takes me to the first scene.

    Any help would be appreciated. Its driving me crazy what the problem is. I have tried recreating everything from scratch & it still happens.

    Thanks

    Deb

  2. #2
    Arr!
    Join Date
    Aug 2002
    Posts
    104
    attach a copy of the fla so we can take a look?

    have you made sure its gotoandstop("finalscene",1)
    else it may just play through that single frame and go back to the first scene again

  3. #3
    shorter than most, but not all findShorty's Avatar
    Join Date
    Apr 2002
    Location
    brisbane
    Posts
    239
    can you post the code you're using?

    remember that gotoAndPlay() is an action and accepts the following different parameters - frame number: frame name: scene and frame number: or scene and frame name.
    MovieClip.gotoAndPlay() is a method of movieclip, and only accepts frame number as a parameter.
    what you may be doing is using a method with a frame name, and this will take you to frame 0 (actually frame 1 as frame 0 does not exist)

  4. #4
    Member
    Join Date
    May 2000
    Posts
    34

    Unable to upload file

    Could I email you the file?

    Thanks

    Deb

  5. #5
    shorter than most, but not all findShorty's Avatar
    Join Date
    Apr 2002
    Location
    brisbane
    Posts
    239
    sure. if you take all the images and sound out of the library. i'm on dial up so very sloooow connection.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center