I am making a PHP passowrod protected page.

I just have one question

in the header info on this script I am wondering if its not compatable with my server. here is the first part of the script
PHP Code:
<?  
header("Pragma: ");  
header("Cache-Control: ");  
header("Expires: Mon, 26 Jul 1980 05:00:00 GMT");  
header("Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT");  
header("Cache-Control: no-store, no-cache, must-revalidate, proxy-revalidate");  
header("Cache-Control: post-check=0, pre-check=0", false);  
//set global variables  
global $username,$password;

where it has the header expire date to 1980 is that going to make it not work?, cuz its not authenicating the password in the script and giving me to the protected page.