I tried to modify one of my flash movie to use with shared library and divided the scenes into some different swf files. A shared.swf file then created and all the instances in the library panel are exported. In shared library properties panel i assigned the URL: shared.swf.
And then from the main movie's library i imported some instances from shared.swf and create link. When i published the movie, I was surprised because the file now is only about the half of the origin(if not using shared library) and all the instances are shown as expected.
But then there is a problem: ALL ACTIONS OF THE BUTTONS DO NOT WORK....!! (even for only go to the next frame action!)

Another problem is i used the preloader for the shared.swf, but all the text (you know, LOADING....), the bar and the percentage are shown after the downloading process has been arrived to about 50% (not from 0%), and before that the file is just blank. I tried to add a scene and put after preloader scene, then drag all the exported instances into scene. But it didnot help.

The action script i used is working in other files, but the problem above is happened when i add (only) one instance (that labels as exported) into the library.

This is the preloader action script (copy from FlashKit.com):

if (_root._framesloaded>=_root._totalframes) {
gotoAndPlay ("assets", 1);
} else {
downloaded = math.floor((_root.getbytesLoaded()/_root.getbytestotal())*100) add "%";
bytesloaded = math.floor(_root.getbytesloaded()/1000);
bytestotal = math.floor(_root.getbytestotal()/1000);
message = bytesloaded add "Kb of " add bytestotal add "Kb downloaded";

##### Then at the next frame:
gotoAndPlay (1);

Is there anybody there could help me, please.. Shared Library is really helpful i think, unfortunely i stucked with those problems.

Thank you very much