A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: PHP form script not working from Projector

  1. #1
    Senior Member
    Join Date
    Aug 2001
    Location
    New York City
    Posts
    409

    PHP form script not working from Projector

    I have a script made in PHP (it's a mail form script that sends the responses from flash fields directly to my email)
    -
    and it works when my swf is on the server -
    BUT not when the projector is running locally or from a CD.
    -
    Is there anything special that I need to do to make this work loacally as a projector file ??

  2. #2
    Registered User nunomira's Avatar
    Join Date
    May 2002
    Location
    portugal
    Posts
    7,003
    hi,

    I know that the test player always uses GET, even if you specify POST.
    This could be the problem... if you're using POST, i.e., try GET.

  3. #3
    Senior Member
    Join Date
    Aug 2001
    Location
    New York City
    Posts
    409
    I changed it to "GET" and I still get no connectivity.
    -
    Do you know of a streamlined PHP script that would be helpful -
    maybe I should change the script all together.

    Thanks !

  4. #4
    Member
    Join Date
    Aug 2003
    Posts
    30
    There's no 'server' to send the mail in your projector. The user would have to have an internet connection open when they open your projector file, and you'd have to send the data to the url of the php script that handles the emailing on your server. Do you have the full url in there?

  5. #5
    Senior Member
    Join Date
    Aug 2001
    Location
    New York City
    Posts
    409
    I still can't get this thing to work from a projector file. I have my PHP script configured like this :
    /************************************************** *****

    Enter your site details below!

    ************************************************** *****/

    // Enter your contact email address here
    $adminaddress = "smiceli@ghgroup.com";

    // Enter the address of your website here include http://www.
    $siteaddress ="http://files.ghgroup.com/_intranet/form/";

    // Enter your company name or site name here
    $sitename = "Zebra";
    -
    this is where my script named "mailform.php" lives :
    http://files.ghgroup.com/_intranet/form/
    -
    Is there something that I'm missing, assuming that there is an internet connection.
    Thanks !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center