Good morning everybody an thank you for reading this!

All I want to do is to run a .swf in a phpnuke 7.0.

sounds easy, doesn´t it?

The Problem is:
My 1st.swf should load a 2nd.swf on frame 21 and stop then.

loadMovieNum("2nd.swf",4);
stop();

What it does:

It shows 1st.swf!
... and thats about it!

What it doesn´t:

It does not load "2nd.swf",4

(both files are in the same directory)

Everythings great on a normal HTML site.
Works wonderfully.

Here ist the code that I used in the php file:

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

if (!eregi("modules.php", $_SERVER['PHP_SELF'])) {
die ("You can't access this file directly...");
}

require_once("mainfile.php");
$module_name = basename(dirname(__FILE__));
//get_lang($module_name);

$pagetitle = "- $module_name";
include("header.php");

OpenTable();
?>

<div><object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0"

name="intro" width="800" height="500" align="absmiddle" id="1st">
<param name="movie" value="modules/test/1st.swf">
<param name="wmode" value="transparent">
<param name="quality" value="high"><param name="SCALE"
value="exactfit">
<embed src="modules/test/1st.swf" width="800" height="500"
align="absmiddle" quality="high"
pluginspage="http://www.macromedia.com/go/getflashplayer"
type="application/x-shockwave-flash" wmode="transparent"
scale="exactfit" name="intro"></embed></object></div>

<?php
CloseTable();
include("footer.php");
?>

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

I tried to post this in a nuke forum and was told to get away
from there, because it is flash´s fault.

No way. I don´t believe this.

It must be a phpnuke problem,
because it works as long as it doesnt run in php.

What have I done wrong so far?

Could you please give me a clou?

Thank you very much

Gustav