this is something I havent had to deal with in awhile, but I need to make sure that my users have a minimum level of Flash to view my content. They will need to upgrade the player to view content if they do not have minimum player.

I am familiar with how to detect flash version with js and as.

I want to make a streamlined process for upgrading the player and would rather they not leave my site to download the player.

It is my understanding that I can set the flash version at the end of the CODEBASE parameter to cause Windows IE to automatically download and install the latest ActiveX control player if the user's version is less than the version I specify in the CODEBASE.

Is there a similar feature for the plug-in or is it best to rely upon JS to detect major/minor version and redirect user to download page at MM web site?