A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: Paths - More Trouble On This Path Than Little Red Riding Hood

Hybrid View

  1. #1
    Getting Better With Time
    Join Date
    Jun 2001
    Location
    Canada
    Posts
    54

    Paths - More Trouble On This Path Than Little Red Riding Hood - still no luck

    Hello there,

    I am having a bit of trouble with a site I am making .
    Here is what I've done.

    a) I've constructed a main page where I have my header and buttons for navigation at the top. At the bottom I have a footer with some basic contact info.

    b) In the middle I have various pages load. I have used the following code to load these movies.

    //Projects Button - loads the Projects SWF file into the main time line.
    function openProjects() {
    _root.createEmptyMovieClip("siteContentPage_mc",_r oot.getNextHighestDepth());
    _root.siteContentPage_mc.loadMovie("../projects/Projects.swf");
    _root.siteContentPage_mc._y=68;
    _root.siteContentPage_mc._x=0;
    }



    Now the problem I am having occurs after this page successfully loads a new set of buttons for a person to select to see various completed projects.

    In this movie called Projects.swf, I want to create another empty movie clip, where another page can be displayed beneath the new set of buttons. I am having a tough time figuring out the path to get the movie to load correctly in my browser. I've tried many variations with the code, but it has not proven to be very successful. Here is what I've done:


    _root.siteContentPage_mc.createEmptyMovieClip("Loa dedPortfolio_mc",_root.siteContentPage_mc.getNextH ighestDepth());
    _root.siteContentPage_mc.LoadedPortfolio_mc.loadMo vie("instructions/Instructions.swf");
    _root.siteContentPage_mc.LoadedPortfolio_mc._y=17;
    _root.siteContentPage_mc.LoadedPortfolio_mc._x=135


    I don't even know if this is on the right wavelength now. Can someone please edit my code, so that I can go to sleep . I posted this earlier, but had difficult understanding what it is that I need to do. If you wouldn't mind, I would also love to have someone explain what it is that they did to fix the code. I know that is asking a lot, but any help is greatly appreciated.

    If you would like to see the site it is at www.modainteriordesign.ca

    Thanks for your help,

    Greg
    Last edited by prestigeinteractive; 02-05-2006 at 06:27 AM.
    ____________________________
    Greg White
    http://www.prestigeinteractive.com

  2. #2
    Qwaizang:syntax_entity_ Q__Hybrid's Avatar
    Join Date
    Aug 2005
    Posts
    270
    Try this:
    Code:
    _root.siteContentPage_mc.createEmptyMovieClip("LoadedPortfolio_mc",_root.siteContentPage_mc.getNextHighestDepth());
    _root.siteContentPage_mc.LoadedPortfolio_mc._y=17; 
    _root.siteContentPage_mc.LoadedPortfolio_mc._x=135;
    
    _root.siteContentPage_mc.LoadedPortfolio_mc.loadMovie("instructions/Instructions.swf", "GET");
    I don't see any problems with your code other than this possibility. Also check to see if "Instructions.swf" is actually capitalized and not actually named "instructions.swf" with a lower-case "I". I knows it's such a little thing, but it matters anyway.

    +Q__

  3. #3
    Getting Better With Time
    Join Date
    Jun 2001
    Location
    Canada
    Posts
    54

    Still trying to get it...Path Problem

    http://www.modainteriordesign.ca/help/

    I tried what you had suggested. Sadly it did not work. Above is a like to a .rar of the site. I would love it if someone could open it, and then get my link to work.

    Thanks for your help.
    ____________________________
    Greg White
    http://www.prestigeinteractive.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center