A Flash Developer Resource Site

Results 1 to 5 of 5

Thread: Dynamic Text kills button below it

  1. #1
    Member
    Join Date
    Mar 2004
    Location
    london, england
    Posts
    41

    Dynamic Text kills button below it

    This seems like a quirky problem, maybe something simple..

    I have an mc on stage with a mouse over event and a click event, the button is used many times on the stage and I'm using a dynamic text box placed over the buttons, but when I test the movie the rollover on the movie clip only works in the areas not covered by the dynamic text field.

    I had this working no problem in AS 2.0 and nothing I've changed should interfere with this - I've tried embedding the font and no good.

    Does anyone have any ideas?

    Thanks,

    Toby

  2. #2
    anyone else hear that? flashpipe1's Avatar
    Join Date
    Jan 2003
    Location
    Upstate NY
    Posts
    1,930
    Make sure your dynamic text isn't set to "selectable" and doesn't have an embedded url...

    Hope that helps!!
    Love like you've never been hurt, live like there's no tomorrow and dance like nobody's watching.

  3. #3
    Member
    Join Date
    Mar 2004
    Location
    london, england
    Posts
    41
    no additional options checked except that it's embedded. It seems like maybe AS 3.0 needs a command to completely disable a text box except for actually displaying the text - in the same way that you now must enable button mode to show the hand cursor for buttons. I couldn't find anything in the documentation though..

  4. #4
    Mod cancerinform's Avatar
    Join Date
    Mar 2002
    Location
    press the picture...
    Posts
    13,448
    nameoftextfield.mouseEnabled = false;
    - The right of the People to create Flash movies shall not be infringed. -
    | www.Flashscript.biz | Flashscript Biz Classes/Components |

  5. #5
    Member
    Join Date
    Mar 2004
    Location
    london, england
    Posts
    41
    twice in one week you've saved me a lot of head-scratching, cancerinform, many thanks.

    On a sidenote, this seems illogical to me - while adding this capability in AS 3.0, it seems like it should be enabled by default. Maybe it's there to ensure links in html dynamic fields work without fiddling..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center