A Flash Developer Resource Site

Results 1 to 8 of 8

Thread: Need help dealing with movie clips - URGENT

  1. #1
    Junior Member
    Join Date
    Nov 2007
    Location
    Seattle, WA
    Posts
    18

    Need help dealing with movie clips - URGENT

    I am making a website, and I have made the page transitions a movie clip. The first page transition is 30 frames long and on the 30th frame a stop code is present. I inserted the clip on a keyframe at 101 and extended it till 131. Frame 132 contains the new page with a button on it. This works fine.

    Now for the second page. It is also 30 frames long, and also has the stop code on the 30th frame. It starts on frame 164 and I extended it to frame 194. Frame 195 contains the new page and a button. But when I test the movie, the button never shows up! It gets to the end of the movie clip and stops, without moving on to the 195th frame. In the movie I did Debug>Show Objects and it says that the movie is on frame 164 still, though it is at the end of the 30 frame movie clip!

    I don't understand why the second page will not move onto the next frame because I did the exact same thing for the first one and it works fine. If someone has any idea what is wrong, I would greatly appreciate your help.

    Thanks for reading and taking the time to look at my dilema.

  2. #2
    FK's Geezer Mod Ask The Geezer's Avatar
    Join Date
    Jul 2002
    Location
    Out In The Pasture
    Posts
    20,490
    I'm betting the stop action in the transition clip has stopped the main timeline. Without seeing the timeline layout it's hard to tell though.

  3. #3
    Ryan :D ryanp321's Avatar
    Join Date
    Nov 2007
    Location
    Wallasey
    Posts
    292
    What version are you using please?

  4. #4
    Junior Member
    Join Date
    Nov 2007
    Location
    Seattle, WA
    Posts
    18
    Im sorry I left that out. I am using Flash 8.

    Also I have attached a zip with .fla in it if that can help anyone understand or offer a solution to my problem.

    Thanks guys
    Attached Files Attached Files

  5. #5
    Junior Member
    Join Date
    Nov 2007
    Location
    Seattle, WA
    Posts
    18
    Oh, and about the stop code, I was wondering the same thing. So i went to the movieclip and deleted the stop code, this just caused the movie clip to loop endlessly though.

  6. #6
    Junior Member
    Join Date
    Nov 2007
    Location
    Seattle, WA
    Posts
    18
    I hope bumping is allowed. If it isn't, sorry. Still need help with this ASAP. Thanks

  7. #7
    FK's Geezer Mod Ask The Geezer's Avatar
    Join Date
    Jul 2002
    Location
    Out In The Pasture
    Posts
    20,490
    I looked at the fla, spent a couple hours on it last night. You have gone about this all wrong. You have graphic symbols, groups, movie clips all mixed up. The only thing that was almost right is the intro movie clip.

    You should build everything on it's own layer, inside the page movie clips. Flowers on their own layer, clouds, all objects on a layer of their own. Layers are free, use them. And don't use graphic symbols, forget they are there, everything should be a movie clip or a button.

    I still don't know why it stops early though, there are too many things not right.

  8. #8
    Junior Member
    Join Date
    Nov 2007
    Location
    Seattle, WA
    Posts
    18
    Yeah I'm new to this still

    I'm sure as I do more projects my organization will get better.

    Thank you very much for your time and putting the effort into this. I found the problem, and I'm sorry to say it was something very minor and something I should have noticed right from the beginning. On the 100th frame, where the main menu is, the buttons for the other 2 flower had to the code gotoAndstop instead of gotoAndplay. That is why it was stopping at the end of the movie clip.

    Thanks for the tips and if anyone is interested, you can check out the project here: http://home.comcast.net/~kyle_d

    Thanks again for the help! And I'm definitely gunna stick around, this place is awesome!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center