A Flash Developer Resource Site

Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Thread: Text pixellating a lot....Is text really vector in Flash ?

Hybrid View

  1. #1
    Senior Member
    Join Date
    May 2009
    Posts
    213

    Text pixellating a lot....Is text really vector in Flash ?

    Hi,

    I have a simple landing page that im making for a website.
    The title to the site. Just plain simple static text but its just always edgy and aliased ?
    I even tried making it orginally in a very large font size breaking it up and then reducing it in size. Still no luck.

    But when i zoom in using the right click menu its starts sharpening up and in real close-up seems razor sharp. But when the page is displayed at 100% size the text which is now much smaller is aliased.

    What is the right way to make sharp text and avoid this problem ?

    Thanks a lot in advance.
    Last edited by plainman007; 05-22-2009 at 03:11 PM.

  2. #2
    Ryan Thomson EvolveDesigns's Avatar
    Join Date
    Oct 2001
    Location
    British Columbia
    Posts
    3,338
    the most likely cause of that is not having your text and any movieclips that house the text on whole x/y coordinates. Select the text and check the properties bar, use whole numbers for x and y.
    Evolve Designs Interactive Media
    the natural selection

  3. #3
    -_-
    Join Date
    Oct 2005
    Location
    US
    Posts
    1,694
    Do you have anti-aliasing on?

  4. #4
    Senior Member joshstrike's Avatar
    Join Date
    Jan 2001
    Location
    Alhama de Granada, España
    Posts
    1,136
    Yeah, the flash standalone player and the compiler don't smooth out vectors in general. Try it in a browser, it'll probably look fine.

  5. #5
    Senior Member
    Join Date
    May 2009
    Posts
    213
    Evolve > Thanks. I never knew even such a small pixel/co-ordinate overlap could create a problem. I will try what you suggested right away.

    AdobeMedia >
    Yes i have anti-alias on. I even tried the 2 options of anti-aliasing and it didnt help.

    Josh > Yes i tried it within the browser. Also by publishing to html. Hasn't helped.

  6. #6
    -_-
    Join Date
    Oct 2005
    Location
    US
    Posts
    1,694
    Could you post a screenshot of what it looks like?

    @evolve
    This is not really the case with anti-aliased fonts, since they are anti-aliased. You only need to make sure of this when working with pixel/bitmap fonts.

  7. #7
    Ryan Thomson EvolveDesigns's Avatar
    Join Date
    Oct 2001
    Location
    British Columbia
    Posts
    3,338
    Quote Originally Posted by Adobemedia View Post
    @evolve
    This is not really the case with anti-aliased fonts, since they are anti-aliased. You only need to make sure of this when working with pixel/bitmap fonts.
    I'm no font ninja so I don't know about the technical side of this, but I've never seen a single font that didn't blur when the x/y cords weren't rounded. I almost always use Verdana/Arial/Helvetica. Would those be pixel/bitmap fonts? All them them blur if the x/y isn't rounded.
    Evolve Designs Interactive Media
    the natural selection

  8. #8
    Senior Member
    Join Date
    May 2009
    Posts
    213
    Hi,

    Tried all above mentioned suggestions. Nothing worked, Same Edgyness. Is it because i shrunk the text slightly in height (wanted the text shorter in style) ?. But im able to see the same edginess even in unaltered text.

    Sure will post images, but i dont know if im allowed to post images here since im just a new member.

    Thanks
    Last edited by plainman007; 05-24-2009 at 10:16 AM.

  9. #9
    -_-
    Join Date
    Oct 2005
    Location
    US
    Posts
    1,694
    You're allowed to attach images.

  10. #10
    Senior Member
    Join Date
    May 2009
    Posts
    213
    AdobeMedia > Hi, I know only one way to grab a screen shot and that is using a screengrabber software. But i dont think ud get the subtle naunces of the aliasing that im talking about. I tried publishing to .PNG and .JPG and the results look horrible even with tweaked jpeg and png settings. How do you suggest i grab the output ?

    Thanks
    Last edited by plainman007; 05-24-2009 at 11:21 AM.

  11. #11
    Senior Member
    Join Date
    May 2009
    Posts
    213
    My apologies for asking such naive questions .

  12. #12
    -_-
    Join Date
    Oct 2005
    Location
    US
    Posts
    1,694
    Just do a print screen, open up the image editing software of your choice, paste, and save.
    Then upload it to some image site, like imageshack or tinypic.

  13. #13
    Senior Member
    Join Date
    Apr 2000
    Location
    Minneapolis
    Posts
    2,127
    How about stripping out the fla file so it contains not much else but the problem text and posting it here so people can test it. Make sure the text if the text is inside movie clips it stays that way.
    Someone will find the problem if they can see the actual file.

    When replying click the "go advanced" button, then below the reply window select the "manage attachments" button.
    Upload you file.

    Mark

  14. #14
    Senior Member
    Join Date
    May 2009
    Posts
    213
    Hi Mark,

    I tried uploading the files. But the forum doesnt let me.
    First it wouldnt let me attach the .html file.
    Then i zipped everything together and it wouldnt let me upload more than 300kb. .
    The fla seems to be 655kb by itself. Its got nothing but a black rectangular movie clip shape for the background and 2 lines of text.
    Is something seriously wrong here ?

    Regards...
    Last edited by plainman007; 05-26-2009 at 02:33 PM.

  15. #15
    Senior Member
    Join Date
    Apr 2000
    Location
    Minneapolis
    Posts
    2,127
    I agree with Ryan. I always put fonts on whole number cords. You can see the difference no matter what anti-aliasing is on and not just pixel fonts.

    plainmann, can you try making a completely new movie with just what shows the problem.
    OR
    go to the library and click "select unused items" delete the selected one, do this again until nothing is selected by the menu command. Then try "save and compact" instead of save.
    You need only post the fla file.

    Is it a font no one is likely to have? You may have to supply that.
    mark

  16. #16
    Senior Member
    Join Date
    May 2009
    Posts
    213
    Ryan & Mark > Hi There !

    I will do that. I think i forgot to delete unused items from the library..

    Ill strip the fla of unused items and post again. I did do the whole numbers thing as Ryan suggested but i couldnt notice much difference. It might help to state that i have also transformed the text manually using Q to sort of squeeze the text vertically as i need the short stubby text look. Maybe that transform is causing the jaggies as it seems a little better when unsqueezed. Anyway i will just post it and see what your verdict is. It might even turn out hard to discover as ive got a very sharp eye, a little too sharp on these things, so you might even end up finding my expectations for sharpness unrealistic.

  17. #17
    Ryan Thomson EvolveDesigns's Avatar
    Join Date
    Oct 2001
    Location
    British Columbia
    Posts
    3,338
    nah, the text should look MINT, I doubt you're being unrealistic. The squishing of the text will definitely have some negative results. Better to look for a font that matches your needs or at least break it (ctrl+b twice) so it becomes straight up vector.
    Evolve Designs Interactive Media
    the natural selection

  18. #18
    Senior Member
    Join Date
    May 2009
    Posts
    213
    Hi,

    I checked the file. Stripped out all imagery etc. Just a black rectangle for the black background and the single line of text (total of only these 2 elements are in the file) and still the .fla file is 656kb i wonder what on earth is wrong with my file ?


    I just went in and deleted the one block of actionscript just to see it if would reduce file size and guess what. The file size went up a notch and now stands at 700kb. Am i doomed..!
    Last edited by plainman007; 05-28-2009 at 01:01 PM.

  19. #19
    Senior Member
    Join Date
    May 2009
    Posts
    213
    Just made a new file at least to e able to upload and solve the text problem.

    Ive attached it here. Ryan & Mark, Please have a look and let me know what you feel.

    Thanks
    Attached Files Attached Files

  20. #20
    Senior Member
    Join Date
    May 2009
    Posts
    213
    Hey Guys,

    Ive attached the file as you asked. Im just bumping this up in case you didnt notice.

    Thanks...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  




Click Here to Expand Forum to Full Width

HTML5 Development Center