A Flash Developer Resource Site

Results 1 to 3 of 3

Thread: Flash CS3 won't open my file

  1. #1
    Junior Member
    Join Date
    Jul 2013

    Angry Flash CS3 won't open my file

    I've been working on my first game for weeks, and I'm almost done. Today I started adding sound when Flash basically crashed. I added background music, which seemed to work just fine. Next I tried adding a sound effect (a few seconds long), and coded it to be played every time an object was added to the inventory. I attempted to test it out, but the loader never progressed beyond the halfway point. I pressed cancel but nothing would happen. I pressed ctrl+s (don't know if it even saved it or not) and x-ed out the program, thinking it was just stuck or that the file for some reason was way too big with just that small addition. When I re-opened flash and tried to open my file (take1.fla), this happened...


    I press OK, and then this...


    I didn't move anything, so I guess it was importing this sound file? If it helps, the first time I imported it the file got corrupted, so I re-saved it with audacity and then it worked just fine. Never got to hear it in-game though.

    Please, I don't want to lose countless hours of work stretched over a few months to be lost like this. Thanks in advance.

  2. #2
    . fruitbeard's Avatar
    Join Date
    Oct 2011

    Try finding the file directly and clicking it open, rather than trying to open a recent file from flash itself, the second error is obviously a path issue.

  3. #3
    Junior Member
    Join Date
    Jul 2013
    I've done so multiple times, it displays the first error but not the second when I do that. For the time being, I've been able to restore a version from 6 days ago. Better than nothing.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

HTML5 Development Center